trailer brake service message - DodgeForum.com

Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > Dodge/Ram Diesel
Log In 


Dodge/Ram Diesel Discussions on all generations of Cummins Diesel powered Rams plus the new Eco Diesel

All times are GMT -4. The time now is 10:10 AM.>

trailer brake service message

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-30-2011, 03:05 PM
keith427 keith427 is offline
Amateur
 
Join Date: May 2010
Vehicle: 2010 2500 megacab 4x4
Location: texas
Posts: 30
Default trailer brake service message

My 2010 2500 megacab 4x4 cummins w/ six speed tranny had a message come up first thing this morning saying "service trailer brake". It was gone after I parked the truck and restarted it later. The message came back up once more later but was off again after a restart. Anybody have any ideas what this means? I haven't pulled a trailer in about 2 weeks.
Reply With Quote
  #2  
Old 10-01-2011, 03:26 PM
keith427 keith427 is offline
Amateur
 
Join Date: May 2010
Vehicle: 2010 2500 megacab 4x4
Location: texas
Posts: 30
Default

So today the message (service trailer brakes soon)came on every time I started my truck. Any body ever see this before?
Reply With Quote
  #3  
Old 10-01-2011, 10:51 PM
lxman1's Avatar
lxman1 lxman1 is offline
Site Moderator
Dodge Forum Moderator
 
Join Date: May 2008
Vehicle: 2008 QC Ram BigHorn Hemi
Location: Louisville, Ky
Posts: 9,145
Send a message via AIM to lxman1
Default

Might check the plug out back to see if maybe water got in it and is shorting something,
I don't know if you will get a code if you scan the PCM.
__________________
2008 RAM 1500 Sunburst Orange BigHorn. 5.7L HEMI

Last edited by lxman1; 10-15-2011 at 09:57 PM. Reason: caint spill vary gud
Reply With Quote
  #4  
Old 10-06-2011, 11:54 AM
keith427 keith427 is offline
Amateur
 
Join Date: May 2010
Vehicle: 2010 2500 megacab 4x4
Location: texas
Posts: 30
Default

The problem is still intermiten. Hooked up my trailer and everything works fine. Then the display comes on again later. It is displaying CF on brake readout which I assume means check fuse but they are all good.
Reply With Quote
  #5  
Old 10-10-2011, 08:30 AM
keith427 keith427 is offline
Amateur
 
Join Date: May 2010
Vehicle: 2010 2500 megacab 4x4
Location: texas
Posts: 30
Default

Saturday morning I went to start my truck and click click the batteries are dead. So after $300 and 2 batteries everything is ok. Apparently they were weak and causing that error message because it has not come back on. Just sucks that batteries only lasted 1 1/2 years and 44,000 miles.
Reply With Quote
  #6  
Old 10-15-2011, 09:57 PM
lxman1's Avatar
lxman1 lxman1 is offline
Site Moderator
Dodge Forum Moderator
 
Join Date: May 2008
Vehicle: 2008 QC Ram BigHorn Hemi
Location: Louisville, Ky
Posts: 9,145
Send a message via AIM to lxman1
Default

Wow, that was a short battery life. I would expect no less than 3 years from an OEM battery.
__________________
2008 RAM 1500 Sunburst Orange BigHorn. 5.7L HEMI
Reply With Quote
 
 
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 dodge ram b1500 v6 3.9l Ronald_Arif Dodge Ram Van 2 08-06-2015 06:30 AM
Towing with a 3.21:1 axle ratio? mcj7247 2nd Gen Ram Tech 13 07-04-2015 06:27 PM
Exhaust smoke, dark; Towing Related Maybe Wh1t3NuKle 2nd Gen Ram Tech 12 06-24-2015 06:12 PM
2006 dodge ram 1500 : spankyj40 3rd Gen Ram Tech 2 06-10-2015 08:59 PM
Sad farewell pierrejoly 3rd Gen Dakota general discussion 4 06-07-2015 09:02 AM

 
Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

Internet Brands, Inc.


Contact Details & Emails