rough idle and check engine light on HELP - DodgeForum.com

Go Back   DodgeForum.com > Dodge Cars > Dodge Stratus
Log In 


Dodge Stratus The Dodge Stratus. Whether you've got a sedan or coupe, base model or R/T, theDodge Stratus has winning looks and thrilling performance.

rough idle and check engine light on HELP

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-07-2011, 09:03 PM
buckeyes8603 buckeyes8603 is offline
Registered User
 
Join Date: Mar 2011
Posts: 3
Default rough idle and check engine light on HELP

02 STRATUS

had a check engine light on scanned code and replaced o2 sensor when i cleared codes and started engine it had a rough idle and wouldnt stay started i unplugged the maf sensor and the idle and problem with staying started was fixed. so i replaced maf sensor and still the same problem i ran the car for about a week and it seemed to get better the engine will stay running however the check engine light came back the nextday and the engine is still running rough while in idle.

if i still unplug the maf sensor the engine is fine im lost please help

Last edited by buckeyes8603; 03-07-2011 at 09:25 PM.
Reply With Quote
  #2  
Old 03-09-2011, 12:25 AM
master tech's Avatar
master tech master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,788
Leonard Pierce
Default

Welcome to DF
What is the code that cause the lite to come on? I couldn't tell but what size engine do you have?
__________________
Dodge Master Tech.
Reply With Quote
  #3  
Old 03-10-2011, 08:02 PM
buckeyes8603 buckeyes8603 is offline
Registered User
 
Join Date: Mar 2011
Posts: 3
Default

2.4 sohc 6 cyl dont remember code number but it said o2 sensor catalatic converter major vac leak and something else i dont remember i checked all vac connection and they r fine could a cat converter do something like that i really dont know alot about that stuff
Reply With Quote
  #4  
Old 03-12-2011, 12:32 PM
smokesxt's Avatar
smokesxt smokesxt is offline
All Star
 
Join Date: Aug 2009
Vehicle: 94 Voyager, Modded 95 Voyager
Location: poynette WI
Posts: 802
Default

Most likely not a convertor. A vacuum leak would possibly cause everything you've described.
__________________
Modded 95 Voyager, 94 Voyager

Brandon R Contildes
5/13/85-1/20/2015
Reply With Quote
  #5  
Old 03-19-2011, 02:29 PM
carson11 carson11 is offline
Registered User
 
Join Date: Mar 2011
Posts: 1
Default

We had the same problem today actually. No previous problems. Took the car in for an oil change, drove out and check engine light came on, engine sounds like its gonna blow up at start, breaks dont work, etc. Idiots. Before we picked the car up, they called to ask about replacing engine air filter, told them yes - they realized they didnt have a filter and had to order one and forgot to put hoses back on and didnt put air intake sensor back on. I guess I'm wondering if this can cause potential problems down the road - I'm not picking the car up for us to pay for their mistakes later.


did you try unplugging car battery for ~5min too?

Last edited by carson11; 03-19-2011 at 02:33 PM.
Reply With Quote
  #6  
Old 04-21-2011, 08:57 PM
buckeyes8603 buckeyes8603 is offline
Registered User
 
Join Date: Mar 2011
Posts: 3
Default

scanned code is p0421
Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 V10 Bad camshaft position sensor ? Where can I get one? 95Ram2500v10 2nd Gen Ram Tech 5 02-01-2016 12:09 AM
'96 Indy Without Headlights rampulstilskin 2nd Gen Ram Tech 14 08-19-2015 01:40 PM
Spark plug question 90vnt 3rd Gen Dakota 1 07-07-2015 09:34 PM
New ram owner with dumb questions dael 3rd Gen Ram Tech 3 07-07-2015 08:26 PM
99 Dodge Ram 1500 wont shift into 4th gear Sparky86 2nd Gen Ram Tech 2 07-06-2015 02:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

 

All times are GMT -4. The time now is 10:28 AM.