Go Back   DodgeForum.com > Technical Help & Information > Technical Archives > General Tech
Sign in using an external account
Register Forgot Password?


General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Odometer not working

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-03-2007, 05:59 PM
wjones76x wjones76x is offline
Garage is empty, add now
 
Join Date: Sep 2007
Location:
Posts: 1
Default Odometer not working

OK guys, I have a 91 Dynasty 3.3 and the Odometer doesn't work any more. All the guages work including the speedo, but I really need the odometer to work so I can claim my milage at work. Any suggestions? I have even tried a junk yard cluster and it still doesn't work. Thanks!
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
__________________
Warren
Reply With Quote
  #2  
Old 09-08-2007, 12:56 AM
ronjester ronjester is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2007
Vehicle: '90 Dodge Ram
Location: Des Moines
Posts: 2
Default RE: Odometer not working

I'm running around in an 89-90 Dodge Ram and I have the same problem, no odometer but speedometer and every other gauge works fine... Any suggestions ?
Reply With Quote
  #3  
Old 09-11-2007, 02:35 AM
mongoose_Fear93 mongoose_Fear93 is offline
Garage is empty, add now
 
Join Date: Dec 2006
Posts: 21
Default RE: Odometer not working

well one thing is to take apart the dash and get into the back of the isterment cluster and follow the wire for it back to the transmission and see if it is broken or corroded or anything else happened to it
Reply With Quote
  #4  
Old 09-20-2007, 08:41 PM
billygyro billygyro is offline
Garage is empty, add now
 
Join Date: Sep 2007
Location:
Posts: 2
Default RE: Odometer not working

hello all, i have a 89 durango with a 5.2 lit. 4x4, when i bought it,it had some problem's- check eng. light on,no speed o-,3/4 shift sel-code, ,,, i changed the wireing harnes and sel,on the inside of the tranny first, then it had the same thing come back up right away,so then found it to be a bad ECM, i changed that and it fixed the problems right off. but now the speed-o in the dash works only when it is cold, as soon as it worms up- my scanner will tell me it is on 0 or even 153 mph. sometimes it put's it into a limp mod,and has a speed signal code. is this still a computer problem??? note,when i changed the computer i was told to have it flashed for the vihecle, but this one came up with a no flash computer modle at o-rileys. i did change the speed sen, and harness for it as well. any idea's????
__________________
billy j. steward
Reply With Quote
  #5  
Old 09-22-2007, 11:07 PM
ontario country boy ontario country boy is offline
Garage is empty, add now
 
Join Date: Nov 2006
Posts: 8
Default RE: Odometer not working

hmmmm somewhat same problem with my 93 dodge ram diesel, All guages work fine excet my speedometer and odometer. Needed a new PCM so replaced it and still no speedo or odometer. Got a replacement under warranty and still same problem. When I put in a PCM from a gas truck totally different year speedo worked but jumped, and not stabile, so new all wiring etc was good. Took it to the dealer and diesel mechanic is convinced PCM is defective. ($500.00 later)When truck is cold and check engine light comes on I have both aspeedometer and odometer. Of course my overdrive relies on my speedo to be working. Mechanic called chrysler who said crankshaft speed sensor needed changing. Changed that and still same problem. Another $200.00 Kicker is when driving if we put truck in nuetral and shut it off speedo works. Wondering if ground to back of speedo is not working and when check engine light is on if getting a ground and allowing it to work. maybe this will help youguys, or if anyone can offer assistance to my problem. Someone else also suggested ignition switch.
Paul
Reply With Quote
  #6  
Old 09-28-2007, 11:18 AM
stonentwolf stonentwolf is offline
Garage is empty, add now
 
Join Date: Sep 2007
Posts: 31
Default RE: Odometer not working

On the dodge ram, to fix the speedometer issue, you need to replace the sensor that sits on top of the rear differential.
Reply With Quote
  #7  
Old 10-02-2007, 06:52 PM
ontario country boy ontario country boy is offline
Garage is empty, add now
 
Join Date: Nov 2006
Posts: 8
Default RE: Odometer not working

Thanks for the info. Everything works fine when the check engine light is on. Speedo worked instantly when a PCM from a gas truck was installed. Still think I need to change the sensor? Mechanic has gone over it for 5 hours, checking everything out. Thanks
Reply With Quote
Old 10-02-2007, 06:52 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 09:54 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2