Go Back   DodgeForum.com > General > New Member Area
Sign in using an external account
Register Forgot Password?


New Member Area New to DF? Stop in tell us about you.

Help with a 2008 caravan issue

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-17-2013, 10:53 AM
jlbrennan jlbrennan is offline
Registered User
 
Join Date: Sep 2013
Posts: 3
Default Help with a 2008 caravan issue

WE have a 2008 Dodge Caravan. There was a strong odor recently which we determined was antifreeze leaking from the Y connector. My husband made a repair and there is no longer any visible leak but the odor is still present though lessened. Smells more when idling. Also, this may be unrelated but the car puts out a lot of heat when none of the systems are on. If the AC or Heat are running it is fine but is nice weather when you don't need them on it is really hot! Nothing coming out of the vent but it just seems to radiate heat.HELP. Frustrated at we have already put a lot of money in this vehicle.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 09-17-2013, 11:28 AM
HeyYou's Avatar
HeyYou HeyYou is online now
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 32,605
Default

It will take a bit to burn off the spilled coolant. Give it a couple days, if it still stinks, start looking for another leak.

As for the 'always blowing heat'..... I don't know how that system works... post up in the caravan section, someone there will have a clue.

Welcome to DF!
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #3  
Old 09-17-2013, 11:47 AM
TNtech's Avatar
TNtech TNtech is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Sep 2010
Location: Nashville, Tennessee
Posts: 2,064
SKMC69
Default

Quote:
Originally Posted by jlbrennan View Post
WE have a 2008 Dodge Caravan. There was a strong odor recently which we determined was antifreeze leaking from the Y connector. My husband made a repair and there is no longer any visible leak but the odor is still present though lessened. Smells more when idling. Also, this may be unrelated but the car puts out a lot of heat when none of the systems are on. If the AC or Heat are running it is fine but is nice weather when you don't need them on it is really hot! Nothing coming out of the vent but it just seems to radiate heat.HELP. Frustrated at we have already put a lot of money in this vehicle.
There is a heat shield under the tunnel in the center of the dash (under the car) If it came off or someone took it off to do some exhaust work, major heat will radiate up from it. Possibly even welded aftermarket Cat too close to body. Have a look under there. Just a first thought anyway.

Welcome to DF X2
__________________
CHRYSLER-JEEP-DODGE-RAM
Master Technician
Electrical & Drivability


My Other Hobby
Reply With Quote
  #4  
Old 09-18-2013, 08:41 AM
jlbrennan jlbrennan is offline
Registered User
 
Join Date: Sep 2013
Posts: 3
Default

Thanks for both responses. FYI, the repair my husband made was over a month ago. He said the same thing, give it time to burn off but a month later it is still there. So I am guessing from what you area saying there is another leak we can't see. Ugh. Can I say I hate this vehicle. We replaced the transmission after less that 50,000 miles, radio does not work, the heat is so uncomfortable in spring/fall when no systems are on and now this. (this is the short list). Sorry, I am frustrated.
Reply With Quote
  #5  
Old 09-18-2013, 09:15 AM
jkeaton's Avatar
jkeaton jkeaton is online now
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: Various
Location: Winston Salem, NC
Posts: 12,397
Kent Eaton
Default

Quote:
Originally Posted by jlbrennan View Post
Thanks for both responses. FYI, the repair my husband made was over a month ago. He said the same thing, give it time to burn off but a month later it is still there. So I am guessing from what you area saying there is another leak we can't see. Ugh. Can I say I hate this vehicle. We replaced the transmission after less that 50,000 miles, radio does not work, the heat is so uncomfortable in spring/fall when no systems are on and now this. (this is the short list). Sorry, I am frustrated.
Your frustration is understandable. Try posting your issues in the Caravan section. Thats where all the Caravan experts reside. Welcome to DF!
__________________


2013 Dodge Journey SXT
2005 Mitsubishi Eclipse GT Spyder
2004 Hyundai Tiburon GT
1995 Ford Mustang
1995 Chevy Z71 K1500
Reply With Quote
Old 09-18-2013, 09:15 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 05:19 PM.

Internet Brands, Inc.


Contact Details & Emails