blinking check engine light and rough ride - DodgeForum.com


Off Topic A place to boldly go off topic. Just about anything goes.

blinking check engine light and rough ride

Reply
 
 
  #1  
Old 02-11-2009, 12:06 AM
cecandrc
cecandrc is offline
Registered User
Thread Starter
 
Join Date: Feb 2009
Posts: 1
Default blinking check engine light and rough ride

I have a 2007 Dodge Ram 1500 3.7L after washing the engine w/ engine cleaner and rinsing away as directed the truck ran fine the next morning to work. That night when I drove the truck the check engine light started flashing and it felt like I was driving over rumble strips in the road for the entire way home. I checked for error codes by turing the ignition on off on off three times but no codes just the word "done" appeared. Any suggestion as to what it can be and what to check?
Reply With Quote
  #2  
Old 02-11-2009, 12:32 AM
JimkDaAdtman's Avatar
JimkDaAdtman
JimkDaAdtman is offline
Veteran
 
Join Date: Dec 2008
Location: Columbus OH IO
Posts: 498
Default

It sounds to me like you fried your computer, and blew the motor... Your truck is now toast... I'll give ya $100 for it.....

ok, seriously... I dunno, could be some water got in to some of the areas it ought not.. Usually this happens when you get moisture in the injectors.. Stuff like that.. Could smooth itself out pretty soon...
Reply With Quote
  #3  
Old 02-11-2009, 01:27 AM
OneBadKota
OneBadKota is offline
All Star
 
Join Date: Feb 2006
Location: New Baltimore, Mi
Posts: 933
Default

Did you cover the electronics on it? If not, more than likely there's some cleaner/water messing with something. I'm not familiar with the 3.7's, does it have a distributor? If so, you might have some water inside the cap. Pop it off, check it, dry it out if need be and try again.



If you ever clean your motor again, just use straight water while it's running, or while cool go over it with some simple green and spray it off and let it dry out. Always cover the electrical stuff.
Reply With Quote
  #4  
Old 02-12-2009, 01:49 PM
tazman6789
tazman6789 is offline
Veteran
 
Join Date: Feb 2007
Location: Mentor, Ohio
Posts: 420
Default

Take it to local autozone and they will hook it up to the computer and see what the check engine light is on for that narrows down to what u might have a bit of water in, once u narrow it down, shoot some wd-40 in the electrical connectors dump the extra out and try again see if it still running rough
Reply With Quote
  #5  
Old 02-14-2009, 08:36 AM
penkowski87
penkowski87 is offline
Registered User
 
Join Date: Feb 2009
Posts: 1
Default bad performance

mine did the same thing its called engine misfire. pull your coils off the plugs and remove the plugs you will see moisture on the outside of the plugs dry them off and reassemble. probblem goes away.
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dael
3rd Gen Ram Tech
6
06-18-2016 10:49 PM
95Ram2500v10
2nd Gen Ram Tech
5
01-31-2016 11:09 PM
90vnt
3rd Gen Dakota
1
07-07-2015 08:34 PM
huffp2
3rd Gen Ram Tech
0
07-07-2015 12:13 AM
Sparky86
2nd Gen Ram Tech
2
07-06-2015 01:12 PM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 02:59 PM.