Go Back   DodgeForum.com > Dodge SUVs > Ramcharger, Trailduster & Power Wagon
Sign in using an external account
Register Forgot Password?


Ramcharger, Trailduster & Power Wagon Grrrr!! Tough Trucks! The Dodge Ramcharger and Plymouth Trailduster were full size SUV's that had good looks and brute strength. The Dodge Power Wagon was comparable to them in toughness, but came in pickup truck form only.

Turn Signals, Hazards, Brake Lights not working

Reply
 
 
 
 
Thread Tools Search this Thread
  #21  
Old 04-23-2012, 08:37 AM
Mastodon Mastodon is offline
Registered User
 
Join Date: Apr 2012
Posts: 3
Default WD40 Fix

After reading a ton of posts, I stumbled across a thread that showed the hazards switch can get stuck and cause all of the above issue. In the thread they recommended spraying the hazard switch with WD40 to make sure it wasn't stuck. Worked like a charm, I now have signals brake lights and reverse.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #22  
Old 05-01-2012, 10:08 AM
Purple97Ram Purple97Ram is offline
Registered User
 
Join Date: Apr 2012
Vehicle: 1997 Dodge Ram 1500 Laramie SLT
Location: Tallahassee, FL
Posts: 4
Default

Ok, I feel silly now. Only the rear flasher/turn signals, and brake lights did not work. I had only checked the right taillight which looked fine so I thought the problem was not the bulbs. I had checked fuses, wires to the rear, replace multifunction switch with a used one and finally after HeyYou's post in this thread did I go back and check the left bulb. It was blown, and the right bulb started working after I moved it around some. I also removed the trailer harness, cleaned, and replaced it. so now they work and a big thanks goes to all you who posted.
Reply With Quote
  #23  
Old 05-24-2014, 03:01 PM
furry_walls furry_walls is offline
Registered User
 
Join Date: May 2014
Posts: 1
Default

ok, I am having issues with my hazards, all turn signals work fine, but when i turn on the hazards only the right side works, originally the right side blinked at normal pace but the noise from the flasher relay was way louder, so i replaced the flasher relay. I now have a similar issue all the turn signals still work, but the right side hazards only work but now they blink rapidly
Reply With Quote
  #24  
Old 05-24-2014, 03:10 PM
HeyYou's Avatar
HeyYou HeyYou is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 34,571
Default

What year is your truck?
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #25  
Old 05-27-2014, 10:29 PM
runsamuk runsamuk is offline
Registered User
 
Join Date: May 2014
Posts: 2
Default Turn Signal/Break/hazard don't work

okay.. I've read all of the posts about electrical problems.. but I didn't see mine..I have 1999 ram 2500...passenger side lights/brake lights and flashers don't work...(the actual lights on exterior) on the console ((interior )shows that i've turned the lever and works fine for drivers side but flashes quickly and rapidly (like if bulb is out) ) . I do not have brakes, hazards or turn signals on the passenger side only. Everything works fine on drivers side... front turn signal on passenger side flashes quickly (like bulb is out).but it does light up... I've checked, rechecked then checked again the bulbs and fuses.. I don't see anything out...
the fuse for my tow lights (fuse box under hood) was out and I replaced it.. but this problem just started when when hooked up to our trailer and the wiring on it was shot. could this be the multi-function switch located on the panel?..

Both sides will light up when I turn on the headlights..still no brake lights, flashers or blinkers on pass side.. and the reverse lights do work.on both sides..(I've switched the bulbs so I'm sure it's not a bulb thing)
Reply With Quote
  #26  
Old 05-28-2014, 10:27 AM
HeyYou's Avatar
HeyYou HeyYou is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 34,571
Default

Check the wiring harness where the trailer harness hits it. Those have been notorious for failing.

Welcome to DF!
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #27  
Old 05-28-2014, 10:33 AM
runsamuk runsamuk is offline
Registered User
 
Join Date: May 2014
Posts: 2
Default

TY!... I'll try that tonight..
Reply With Quote
  #28  
Old 09-26-2014, 03:42 PM
kikoflores kikoflores is offline
Registered User
 
Join Date: Apr 2008
Vehicle: Dodge Ram 1500 1997
Location: San Diego
Posts: 4
Default Need HELP

I have a 1997 Dodge Ram 1500, The problem I have is a electrical problem, All my lights turn on exempt the left rear brake in signal. I change the light bulbs, change the left rear light harness, checked for ground, checked the trailer harness. Got power from the trailer harness. The only thing is that the brakes and signal light does not turn on but the running light do. Left side.. But I do get front left side turn signal, but no rear. Dont want to buy a manuel just to see where the ground goes or have a electrical box some where in the rear. Just need a simple diagram of the rear..
Reply With Quote
  #29  
Old 09-26-2014, 04:03 PM
kikoflores kikoflores is offline
Registered User
 
Join Date: Apr 2008
Vehicle: Dodge Ram 1500 1997
Location: San Diego
Posts: 4
Default Need help

[QUOTE=kikoflores;3198115]I have a 1997 Dodge Ram 1500, The problem I have is a electrical problem, All my lights turn on exempt the left rear brake in signal. I change the light bulbs, change the left rear light harness, checked for ground, checked the trailer harness. Got power from the trailer harness. The only thing is that the brakes and signal light does not turn on but the running light do. Left side.. But I do get front left side turn signal, but no rear.
Reply With Quote
  #30  
Old 09-26-2014, 04:12 PM
HeyYou's Avatar
HeyYou HeyYou is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 34,571
Default

Download the 96 manual from this thread. Wiring diagrams in there.

Brake and turn signal are on same filament in the bulb. They also both go thru the turn signal switch.... are you getting power at the bulb??
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #31  
Old 03-09-2015, 10:36 PM
89ramcharger. 89ramcharger. is offline
Registered User
 
Join Date: Mar 2015
Posts: 1
Default

Ok I have a 89 ramcharger and have no turn signals, i have lights in the back but no brake lights when pedal is pressed BUT if I turn hazard lights on my right turn blinker will blink if i wiggle the hazard switch around. All connections are good, I have all new fuses and flasher checks out ok, anybody ran into this problem on this model ramcharger before?
Reply With Quote
  #32  
Old 03-10-2015, 09:26 AM
HeyYou's Avatar
HeyYou HeyYou is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 34,571
Default

Moving this to the correct section for you.
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #33  
Old 03-17-2015, 08:24 PM
The War Wagon's Avatar
The War Wagon The War Wagon is offline
Rookie
 
Join Date: Nov 2014
Vehicle: '92 Dodge Ramcharger/'07 Commander XK/'08 Caravan SXT
Location: da' 'BURGH
Posts: 55
Send a message via Yahoo to The War Wagon
Exclamation

My turn signals gave up the ghost the other day. JUST so everyone with the factory Wagner 536 fuse knows;

- this was replaced with the 577
- the 577 was replaced, with the Tridon LF-12

So I figure I'll let the Autozone staff earn their check after searching fruitlessly for a while. The little counter babette asked, "That's a Dodge CHARGER?"

"No maam - 'RAMCHARGER.'"

So I'm watching her run the screens on her cash register, and notice, she's looking through CARS. So I tell her, "It's a truck."

"Oh - OK - I've never even heard of it."

ME: "When were you born?"

"1995."

O - kaaaaaaaaaaay...


So I figured it myself out by process of elimination. And yes, it DOES work.
__________________
'92 Ramcharger - 318 Magnum, 4.56 gears, 4" lift, 35" M/T's, and a CONSTANT work in progress...
Reply With Quote
  #34  
Old 03-18-2015, 08:10 PM
95dodgeramfl 95dodgeramfl is offline
Registered User
 
Join Date: Mar 2015
Posts: 1
Default

Quote:
Originally Posted by tigerhornet View Post
My headlights work fine, but the turn signals, hazard lights, and brake lights don't work. when i hit either the hazard light switch or the turn signal switch, absolutely nothing happens, no click, no indicator lights.

I had the same exact problem, i banged on the hazard switch and it all started working instantly. No hazards still but eh who needs em
Reply With Quote
  #35  
Old 03-29-2015, 06:02 PM
frankieb55chevy frankieb55chevy is offline
Registered User
 
Join Date: Mar 2015
Posts: 1
Default all new everything. .still nothing. blowing 15 amp fuse under hood..what now

Quote:
Originally Posted by BlueBeast2 View Post
My guess would be the multi-function switch
I've replaced all the fuses relays brake switch multifunction switch and I still don't have brake turn or hazards signals?! I'm at a loss...and it is popping the 15amp fuse under the hood...anything you can share would be appreciated
Reply With Quote
Old 03-29-2015, 06:02 PM
 
 
 
Reply




Tags
2000, 2001, 94, blinkers, brake, caravan, dodge, flasher, gt, hazard, lights, mustang, signal, signals, sprinter, turn, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 03:10 PM.

Internet Brands, Inc.


Contact Details & Emails