Truck won't idle when warm - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Dakota > 1st Gen Dakota
Reload this Page > Truck won't idle when warm
1st Gen Dakota '96 & Older Dakota's

Truck won't idle when warm

Reply

 
 
  #1  
Old 11-13-2017, 08:03 PM
HotelCarolina
HotelCarolina is offline
Registered User
Thread Starter
Join Date: Jul 2016
Posts: 10
Default Truck won't idle when warm

Hello all. I have a 1995 Dakota that I just swapped from a 3.9 to 5.2. The first start up went real smooth and fired right up. It idled for around 5 minutes then I cut it off. I tried firing it back up a couple minutes later and I get a very rough idle and it did nothing but stall on me within seconds. I replaced the ignition coil and the MAP sensor but it didn't change anything. This morning I started it and it fired right up and it idled smoothly. I cut it off and was going to go for a test drive thinking it was fine but it did the same thing (rough idle/instant stall). I'm at a dead stop and I don't know what it can be. Some of the sensors that are new: IAC, TPS, MAP, Crank position sensor, Cam sensor, Engine coolant sensor, new PCV. I know I have spark and I know I have fuel but it just doesn't want to stay running. Thanks in advance
Also to note: I am running a V8 computer and the V8 flexplate
 

Last edited by HotelCarolina; 11-13-2017 at 11:47 PM.
Reply With Quote
  #2  
Old 11-13-2017, 10:18 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 46,231
Default

Disconnect the front O2 sensor. See if it will idle.
 
Reply With Quote
  #3  
Old 11-13-2017, 11:19 PM
HotelCarolina
HotelCarolina is offline
Registered User
Thread Starter
Join Date: Jul 2016
Posts: 10
Default

Originally Posted by HeyYou View Post
Disconnect the front O2 sensor. See if it will idle.
Still spits and sputters. It wants to start
 
Reply With Quote
  #4  
Old 11-14-2017, 10:23 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 46,231
Default

If you give it a little bit of gas, will it stay running?

What brand cam/crank sensors?
 
Reply With Quote
  #5  
Old 11-14-2017, 10:53 AM
HotelCarolina
HotelCarolina is offline
Registered User
Thread Starter
Join Date: Jul 2016
Posts: 10
Default

Originally Posted by HeyYou View Post
If you give it a little bit of gas, will it stay running?

What brand cam/crank sensors?
BWD sensors. I can keep it running for little bit when I hit the throttle. RPMs don't go up at all though it just lets more air in then dies
 
Reply With Quote
  #6  
Old 11-14-2017, 11:20 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 46,231
Default

Sensors may be part of the problem. Dodges just don't seem to care for aftermarket sensors in critical locations.

May also want to check fuel pressure.
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 03:42 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: