DodgeForum.com

DodgeForum.com (https://dodgeforum.com/forum/)
-   2nd Gen Dakota Tech (https://dodgeforum.com/forum/2nd-gen-dakota-tech-67/)
-   -   Hard Sputter (https://dodgeforum.com/forum/2nd-gen-dakota-tech/420934-hard-sputter.html)

Lefty2053 01-19-2019 08:14 AM

Hard Sputter
 
I can drive my truck 40 plus miles up on top a mountain and it drives fine. When I come home on the same roads about half way home I get these hard sputters. Real hard. It is like something choked it out. I only get a few of these and then it quits. The rest of the way home it is fine. I really think it is when I have a light throttle cruising and never when I am giving it throttle to accelerate. Any ideas? I was thinking IAC or Throttle control valve. The truck does have one of those stupid K&N filters on it. I made sure the connections are all tight and cleaned it a few times to make sure nothing was getting in.
Any ideas are greatly Appreciated.
1997 Dodge Dakota 5.2 Auto.

HeyYou 01-19-2019 08:44 AM

IAC shouldn't play a role if you have your foot on the gas. Coming home, are you driving downhill, hence, less pressure on the go-pedal? If so, I would look real hard at the TPS.

Lefty2053 01-19-2019 09:16 AM

Nothing when going down hill. Just on flat ground cruising. But light throttle.

HeyYou 01-19-2019 09:20 AM

Test the TPS, just for giggles. Make sure things are good and warm when you test it. Use an analog meter (one with a gauge, with a needle), the digital meters don't react fast enough, and are erratic to begin with, so, testing with one is basically pointless.

Lefty2053 01-19-2019 09:37 AM

Sorry I don't even know how to use one. I can get one today but where do I put the leads?

magnethead 01-19-2019 12:29 PM

What is the elevation change from the mountain on down?

I recall a thread last year about a fella in hawaii having a similar issue coming down the mountain, I recall it was something about pressurization because if he loosened the gas cap the issues went away.

Lefty2053 01-19-2019 01:41 PM

Well I guess I should have said sometimes it does and sometimes it doesn't. Because it will do it also if I go to town 18 Miles and on the way back it will do it. AS for the Mountain it is 10,500 feet and where it sputters it is usually around 4800 feet. But when I go into town it is mostly around 4400-4800 feet.

HeyYou 01-19-2019 04:08 PM

Red lead from the meter goes to the 'signal' wire that goes back to the PCM, (I think it's the center wire, assuming a three pin connector) black lead just goes to a good ground. You will have to poke the red lead into the wire enough to get good contact though..... so, have some electrical tape handy to seal it back up as well.

With the leads in the correct spots, have a friend turn the ignition "on", (don't start the motor) and SLOWLY press the gas pedal down, all the way to the floor. Meter should be set on the lowest voltage range it has. (5 or 10 volts will be fine) Meter should start out at less than one volt with the throttle close, and SMOOTHLY increase to greater than 3.5 volts at wide open throttle. If it bounces around, AT ALL, it's bad, and needs to be replace. Run the test several times, engine warm, if possible..... See what ya get.

Lefty2053 01-19-2019 06:02 PM

HeyYou, thanks for the info. I will pick up a meter tomorrow when I take the wife to work. Just so you know,I only use the truck on occasion and only drive it at most 80 miles round trip.

98DAKAZ 01-20-2019 12:27 AM

I would say your MAP sensor is the problem with or plus a dirty throttle body clean the throttle body first if still a problem look at the MAP sensor.


All times are GMT -4. The time now is 08:58 PM.


© 2019 MH Sub I, LLC dba Internet Brands