Go Back  DodgeForum.com > Dodge Trucks > Dodge Dakota > 2nd Gen Dakota Tech
Reload this Page >

2002 Dakota instrument cluster random off/on

2nd Gen Dakota Tech 1997 - 2004 Dodge Dakota Tech - The ultimate forum for technical help on the 2nd Gen Dakota.

2002 Dakota instrument cluster random off/on

  #1  
Old 04-16-2019, 08:22 PM
ManiacCoder's Avatar
ManiacCoder
ManiacCoder is offline
Registered User
Thread Starter
Join Date: May 2018
Location: Northern Utah
Posts: 5
Angry 2002 Dakota instrument cluster random off/on

A little while ago the instrument cluster in my 2002 Dakota SXT started randomly blinking off and then back on just as if I had turned the power off then immediately back on. This affects all gauges and idiot lights on the cluster but nothing else in the pickup. This behavior is completely random as far as I can tell -- I can go a day or two or three without any issues and then some days it will happen multiple times. It can happen while driving, while stopped, while parked, just after starting or after the truck has been running a while - in short, there isn't any rhyme or reason to it that I can figure out.

I've done the reset procedure a couple of times (battery cable off, key to start) without any apparent impact/change.

Before I start throwing parts at it I thought that I'd ask the forum to see if this feels like maybe the CTM or perhaps the cluster itself is going, or if I should look elsewhere. I'm stumped and haven't come up with anything after several hours of Google and searching on this forum so I'm hoping that someone can point me in a more productive direction on this issue. Thanks!
 
  #2  
Old 04-17-2019, 09:44 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 56,144
Default

Bad connection somewhere. I would start at the back of the cluster itself.
 
  #3  
Old 04-17-2019, 12:03 PM
ManiacCoder's Avatar
ManiacCoder
ManiacCoder is offline
Registered User
Thread Starter
Join Date: May 2018
Location: Northern Utah
Posts: 5
Default

A small update - when driving last night I did notice that the backlighting from when using the lights does *not* blink out with the rest of the cluster gauges. It is only the gauges, odometer & gear indicator areas that blink out - the backlighting stays steady.
 
  #4  
Old 04-17-2019, 12:12 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 56,144
Default

Questionable power feed for the cluster? I don't have wiring diagrams for those handy......
 
  #5  
Old Yesterday, 08:49 AM
Mopar44134
Mopar44134 is offline
Registered User
Join Date: May 2012
Posts: 21
Default

Same problem here. Im thinking dimmer switch possibly. I picked up a 2002 wrecked durango for the drive train. when i get a minute ill swap cluster and switch to see what happens. what i do know on the cluster, it holds the programming for the mileage. Other than that does anyone know if it will work in a 2000 dakota. it will plug right in and looks the same. i pick one up from pull a part, i may have gotten a bad one but it didnt work right.
 
  #6  
Old Yesterday, 09:58 AM
Mopar44134
Mopar44134 is offline
Registered User
Join Date: May 2012
Posts: 21
Default

 

Thread Tools
Search this Thread
Quick Reply: 2002 Dakota instrument cluster random off/on


Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: