DodgeForum.com

DodgeForum.com (https://dodgeforum.com/forum/)
-   2nd Gen Dakota Tech (https://dodgeforum.com/forum/2nd-gen-dakota-tech-67/)
-   -   2001 TRS Mounting Bracket (https://dodgeforum.com/forum/2nd-gen-dakota-tech/423867-2001-trs-mounting-bracket.html)

art20 06-09-2019 11:01 PM

2001 TRS Mounting Bracket
 
Does anyone know where I can get a TRS Mounting Bracket for the Transmission Range Sensor? My Range sensor isn't working properly ever since I had my transmission rebuilt. It only registers D 2 1 and nothing else on the DASH. I have replaced the Range Sensor with a Brand New one and it still does not work. Or does anyone know how I can adjust the LED gear selector on the Dash to show the correct readings? Right now when I place the vehicle in "PARK" the reverse light illuminates. Any help is greatly appreciated. Thanks

magnethead 06-10-2019 10:56 AM

Which engine/transmission?

42/44/46RE screws into the case with two screws, there isnt a bracket per se.

art20 06-11-2019 08:33 AM

TRS Transmission Bracket
 

Originally Posted by magnethead (Post 3441912)
Which engine/transmission?

42/44/46RE screws into the case with two screws, there isnt a bracket per se.

I have the 3.9liter V6 with the 42RE 4-speed Transmission. The bracket I was referring to is called the: Bracket part no# 56049014AA. I found this on: https://www.moparpartsgiant.com/part...0145517&PNC=19

I have already replaced the Neutral Safety Switch and still have the same results with the reverse lights illuminating when the vehicle is in park and nothing is showing on the range selector. I purchased a replacement from rockauto online and it is suppose to be compactible with the 42RE transmission.

primem 06-12-2019 12:17 AM

is the trs indexed correctly to the shift linkage? If yes, try a battery disconnect. I have replaced trs on 6 speeds and if I don't disconnect the battery... the gear indicator shows reverse when its indexed in park.

art20 06-12-2019 07:18 AM

2001 TRS Mounting Bracket
 
Good Morning pimem
Don't know what you mean by " the trs indexed correctly to the shift linkage". How do you get the TRS to index correctly or how to adust the index? And yes, I disconnect the battery for about 15-minutes and the gear indicator shows reverse when its indexed in park. Greatly appreicate any help you can provide.

Thanks

primem 06-12-2019 09:46 AM

FOR the 46RE THEY want the manual shift level in the low position during installation. If not done the maual shift linkage and trs may not be indexed correctly.

art20 06-12-2019 09:48 PM

Okay....let me see if I understand you correctly. 1). disconnect the battery.
2). wait 5 to 10 minutes.
3). shift the transmission into the low gear...which 1 or its lowest gear.
4). reconnect the battery and that should do it.
Okay...I'll give it a try tomorrow to see If that works and let you know. .
thanks
primem

primem 06-12-2019 11:38 PM

no. when the trs is installed...service information wants the shift lever in low. Was the shift lever in park when you installed it?

art20 06-13-2019 07:27 AM

2001 TRS Mounting Bracket
 
no...I had it in "neutral" when I reconnected the battery and then I shifted it back to "Park". I guess I have mess things it up by doing that.

art20 06-13-2019 08:52 PM

good evening primem

well I just finished trying out putting the shifter in low gear and disconnecting the battery for almost 20-minutes and it sort-of worked. Its not showing the reverse light like it was but doesn't exactly show when it in reverse either. Its kinda showing in-between park and reverse gear. But another problem has just showed up.....and this is a major problem. Now I don't have any brakes at all and the ABS and Brake light is on and the brake pedal goes to the floor. This is really crazy when you're so close to fixing 1 problem and another happens. I can't drive this truck to work tomorrow morning with the brakes dead or no brakes at all. You would happen to know the cause....would you?


All times are GMT -4. The time now is 10:07 PM.


© 2019 MH Sub I, LLC dba Internet Brands