DodgeForum.com

DodgeForum.com (https://dodgeforum.com/forum/)
-   2nd Gen Ram Tech (https://dodgeforum.com/forum/2nd-gen-ram-tech-64/)
-   -   No Turn Signals (https://dodgeforum.com/forum/2nd-gen-ram-tech/204436-no-turn-signals.html)

Ramman18 06-17-2009 12:44 AM

No Turn Signals
 
A friend of mine's mom has a 95 2500 4x4 V10 regular cab long box with 150k miles.

The turn signals don't work at all. The hazards work fine and she's replaced the fuse and bulbs.

When the signal handle is pulled on, I can hear one 'tick' like it wants to blink but won't.

Is the switch bad in the column? We don't know where to look. Any help is appreciated.

Oh and the blinker fluid is topped off :)

jasonw 06-17-2009 02:28 AM

The next thing I'd do is replace that lever. $45 ish on eBay or at a junk yard, and a fairly common thing to go wrong.

Diefenbaker 06-17-2009 02:38 AM

First recheck the fuse in the fuse block (the one between drivers door and dash panel). At this fuse block there are also two identical relays. One for turn signal the other one for hazard. Interchange them. If the turn signal works now the relay is faulty. For more detailed wiring check this at page 17

speeddemon31176 06-17-2009 05:09 AM

+1 on checking the relay first. Then change the multifunction switch if the relay doesn't fix it.

Ramman18 06-17-2009 12:50 PM

Thanks everybody, we'll keep you posted.

Ramman18 06-19-2009 12:45 PM

Tire shop fixed it right away. It was some little $5 switch. I think it was called the turn signal instrument. Anyway, they work great and she's happy. Thanks.

goober86442 06-21-2009 11:00 PM

What was the part that they replaced? i am having the same problem but my dodge is a 99 ram 1500 so it a multi hazard/signal flasher which i have replaced.

wjxavier 06-21-2009 11:20 PM


Oh and the blinker fluid is topped off :)

huh?:confused:

Diamond8 05-10-2013 09:21 PM

Has anyone ever figured out what the switch was he replaced?? I am having this EXACT same problem. Running lights work........flashers work.......turnsignals quit......when I move the turn signal lever I can here the relay "click" but not flashing? Any help would be greatly appreciated!!

Dave

zman17 05-11-2013 12:41 PM

The flasher is what they most likely replaced.


All times are GMT -4. The time now is 02:17 PM.


© 2019 MH Sub I, LLC dba Internet Brands