Gauge cluster/ no illumination - Page 2 - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Reload this Page >

Gauge cluster/ no illumination

2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Gauge cluster/ no illumination

  #11  
Old 03-19-2019, 11:43 PM
DerTruck
DerTruck is offline
Rookie
Join Date: Dec 2018
Posts: 87
Default

According to the 2001 FSM fuse "F" in the PDC which is the one that protects the pink/red is a 20A. But if it says 15 in the owners manual or the PDC then stick with that. Either way, fuses can look good but be wonky and present problems. Don't really have a good idea on the 0.6V drop at fuse 5. There's a couple feet of wiring, the big connector on the firewall and a switch along the way but it shouldn't cause that much drop. Maybe there are some corroded contacts but if it works now I'd leave it alone.
 

Thread Tools
Search this Thread
Quick Reply: Gauge cluster/ no illumination


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: