Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Reload this Page >

Speedometer stopped working after transmission fluid change and radiator flush

2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Speedometer stopped working after transmission fluid change and radiator flush

  #1  
Old 04-14-2019, 06:50 PM
Matt Wuerth
Matt Wuerth is offline
Registered User
Thread Starter
Join Date: Apr 2019
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default Speedometer stopped working after transmission fluid change and radiator flush

I changed my transmission fluid today, then flushed the radiator. Disconnected the battery for a few minutes while working on the radiator. Everything went well, and the truck runs fine, but my speedometer stopped working. Any ideas to as why? Maybe a blown fuse? Don't think I got the speed sensor wet or anything.
 
  #2  
Old 04-14-2019, 08:27 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 57,755
Likes: 0
Received 36 Likes on 36 Posts
Default

What year is your truck? Engine? Trans? 2 or 4 wheel drive?
 
  #3  
Old 04-14-2019, 08:35 PM
Matt Wuerth
Matt Wuerth is offline
Registered User
Thread Starter
Join Date: Apr 2019
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by HeyYou View Post
What year is your truck? Engine? Trans? 2 or 4 wheel drive?
98, 5.9l. 46re auto, 4x4
 
  #4  
Old 04-14-2019, 09:04 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 57,755
Likes: 0
Received 36 Likes on 36 Posts
Default

Ok, on yours, the Speedo gets its cue from the rear wheel speed sensor on the top of the rear diff. Check and make sure it didn't simply get unplugged, bumped, broken, or otherwise disturbed during the trans swap process.
 
  #5  
Old 04-14-2019, 09:15 PM
Matt Wuerth
Matt Wuerth is offline
Registered User
Thread Starter
Join Date: Apr 2019
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks. I'll check it
 

Thread Tools
Search this Thread
Quick Reply: Speedometer stopped working after transmission fluid change and radiator flush


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: