Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Reload this Page >

99 Ram Loss of Power at speed

2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

99 Ram Loss of Power at speed

  #1  
Old 06-08-2019, 05:52 PM
99CubbyBlue1500
99CubbyBlue1500 is offline
Registered User
Thread Starter
Join Date: Jun 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default 99 Ram Loss of Power at speed

Bought this 99 1500 5.2 4x4 a week ago. Last night, and again this evening, while driving at 70mph with the cruise set, had a total loss of power on a relatively flat road. Exited the highway, had no real issue accelerating again, to 50mph speed limit, that is. Help please!

Gonna try driving later without cruise on and see if there's a difference.
 
  #2  
Old 06-08-2019, 11:07 PM
Torxhead
Torxhead is offline
Professional
Join Date: Oct 2011
Location: Yorba Linda,Ca.
Posts: 193
Likes: 0
Received 0 Likes on 0 Posts
Default

I have had issues from not using it much, but the problem seemed to go away.
 
  #3  
Old 06-09-2019, 07:53 PM
pershingd
pershingd is offline
Professional
Join Date: Aug 2004
Location: Laquey, MO
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
Default

Scan it and see if any codes were set, but I wouldn't rule out a fuel related issue if it had been sitting for a while before you got it.
 

Thread Tools
Search this Thread
Quick Reply: 99 Ram Loss of Power at speed


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: