3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Acceleration issues

  #1  
Old 06-25-2019, 04:07 PM
JeffRam
JeffRam is offline
Registered User
Thread Starter
Join Date: Jun 2019
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Acceleration issues

I have 2007 Dodge Ram 1500, 2wd, 4.7 v8 engine. Milage 106k miles

I have zero codes and no check engine light on. I have replaced my plugs with Champion double platinum, then all 4 o2 sensors with Bosch brand and all 8 ignition coils with MoPar Brsnd. Sometimes when I start truck up and try to accelerate there is nothing then takes off.

Just a bit ago I was going forward after backing up and I heard a pop sound and had zero acceleration and it was dying. I put it park and shut off and started back up and drove with no loud pops or no acceleration issues.

Would this be a catalytic converter problem or a map sensor? My catalytic converter upstream is black on bottom side.
 

Last edited by JeffRam; 06-25-2019 at 04:10 PM.
  #2  
Old 06-25-2019, 08:07 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 57,628
Likes: 0
Received 34 Likes on 34 Posts
Default

Bosch O2 sensors, and platinum plugs....... two things dodge is notorious for hating..... Did your problems start right after doing those changes?
 
  #3  
Old 06-25-2019, 08:57 PM
JeffRam
JeffRam is offline
Registered User
Thread Starter
Join Date: Jun 2019
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by HeyYou View Post
Bosch O2 sensors, and platinum plugs....... two things dodge is notorious for hating..... Did your problems start right after doing those changes?

My problem started after changing out all 4 of the o2 sensors. Ignition coils didn't help. What brand is recommended for dodge for spark plugs and o2 sensors?
 
  #4  
Old 06-25-2019, 09:26 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 57,628
Likes: 0
Received 34 Likes on 34 Posts
Default

For the plugs, stock, I think, is Champion.... but, I personally don't care for those, and install autolites, or NGKs. (copper core, thankyouverymuch.)

For the O2 sensors, NTK or Denso. (I think both were OEM suppliers at one point or other.)
 
  #5  
Old 06-26-2019, 04:13 AM
JeffRam
JeffRam is offline
Registered User
Thread Starter
Join Date: Jun 2019
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you very much for the help. I really appreciate it!
 

Thread Tools
Search this Thread
Quick Reply: Acceleration issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: