RAM 1500 5.7 4x4 problem - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 4th Gen Ram Tech
Reload this Page >

RAM 1500 5.7 4x4 problem

4th Gen Ram Tech 2009 - 2018 Rams and the 2019 Ram Classic: This section is for TECHNICAL discussions only, that involve the 2009 - 2018 Rams and the 2019 Ram Classic. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

RAM 1500 5.7 4x4 problem

  #1  
Old 01-11-2019, 05:59 AM
Lazov
Lazov is offline
Registered User
Thread Starter
Join Date: Jan 2019
Posts: 1
Default RAM 1500 5.7 4x4 problem

Hi,

I got stuck in very deep show with my Dodge Ram 1500 from 2014 and now I have problem with engaging the 4x4.

I have message on the dashboard saying there was overheating and the performance is temporarly reduced.

When I push 4WD button it starts blinking and then stay solid, like usually, but I don't hear any sound coming under the truck proving the switch.

I checked the fuses, also the wires under the truck, everyting looks fine.

Any ideas?
 

Thread Tools
Search this Thread
Quick Reply: RAM 1500 5.7 4x4 problem


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: