05 Magnum R/T Stalling at Idle. Won't idle under 1200 RPM's - DodgeForum.com

Go Back  DodgeForum.com > Dodge Cars > Dodge Magnum
Reload this Page >

05 Magnum R/T Stalling at Idle. Won't idle under 1200 RPM's

Dodge Magnum The Dodge Magnum, the wagon that made wagons cool. The unique look of the Dodge Magnum makes any trim level, from SE to SRT-8, an absolute head turner.

05 Magnum R/T Stalling at Idle. Won't idle under 1200 RPM's

  #1  
Old 01-02-2014, 10:25 PM
bigcdiver2000's Avatar
bigcdiver2000
bigcdiver2000 is offline
Registered User
Thread Starter
Join Date: Jan 2014
Posts: 2
Angry 05 Magnum R/T Stalling at Idle. Won't idle under 1200 RPM's

Alrighty all. I am new to the sight and relatively new to Dodge ownership. This past year I purchased a 2005 Magnum R/T with the 5.7L Hemi. 150k miles, but in great shape, had all maint logs from the state, as it was a former Highway Patrol vehicle since new. On Xmas eve while driving I started to feel a hesitation and at the very next light it stalled out on me. It would only restart after that if I floor the gas, and feather it over 1500 RPMs, once it drops under 1200 it stalls back out. Only codes that pulled were P0456 and P0457, over the past week I have replaced the fuel pump assembly, Throtle Body, Battery Terminals, Battery (2 months ago, NVLD pump, Cam positioning sensor, Crank positioning sensor, and the IAT sensor. Im 100% out of thoughts as to why it still won't start or idle on it's own. Also nearly out of money now.


PLEASE any HELP!!!
 
  #2  
Old 01-07-2014, 08:56 PM
bigcdiver2000's Avatar
bigcdiver2000
bigcdiver2000 is offline
Registered User
Thread Starter
Join Date: Jan 2014
Posts: 2
Default

Update: Even though I've had no responses and continued to work on it one idea at a time.

So I had a friends start the car with the gas peddle pressed and feathered it to keep RPMs at around 1500 so it wouldn't drop and stall out again. While doing this I tested voltage to the TB (Pink/Yellow) wire, and am getting the required 5 volts.

After checking that I accidentally dropped my mag light on the PCV valve hose (Located on the pass side of the intake manifold and heading into the PCV valve reservoir). The hose must have been severely dry rotted cause it broke. When that happened the car shot up in idle, so I told my friend to let off the gas pedel and see if it stalls out again. It did not, it dropped to idle at 700-800 RPMs as read on my OBDII meter. just kept sucking in vacuum and continued to idle as normal.

Decided to take it out for a test drive and see what happened. My friend followed in case it died out again. The car ran as it should full of power and idled at stop signs. I even took it up to get gas, and it restarted as it should and continued to drive and idle as it should.

When I returned home I plugged it back into the scanner since the engine light was still on, and new codes came up, and old ones were gone. P0445 (Large EVAP leak), and P0507 (High RPM). I assume they could be cause from the car sucking extra air in through the side of the intake manifold now.

SO I will replace the PCV valve and hose tomorrow (Current one is prob the original as it was caked in crap and gross, and I broke the orig hose). Will post anouther update after that to see where I am.

Would still appreciate additional input if any one has any.
 
  #3  
Old 01-18-2014, 05:45 PM
Wile C
Wile C is offline
Professional
Join Date: Feb 2006
Posts: 160
Default

i had a problem with my ram truck doing that. i replaced my IAC idle air control sensor it it fixed my problem. i haven't had any problems with my hemi in my rt/magnum. might try that.

here's some symptoms of a bad one:

Stalls after start when engine is cold
Stalls after start when engine is hot
Stalling on deceleration
Stalls at idle
Unstable idle
Diesels or runs on after the engine is shut off
High idle
Low idle
 
  #4  
Old 12-03-2018, 11:22 AM
RachelR
RachelR is offline
Registered User
Join Date: Dec 2018
Posts: 1
Default Helpful info

My 05 se magnum was having this issue .. my fiancÚ changed the PCV VALVE it was completely clogged and no movement. After changing it my car starts better idles better and has not died randomly. I hope this helps others
 

Thread Tools
Search this Thread
Quick Reply: 05 Magnum R/T Stalling at Idle. Won't idle under 1200 RPM's


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: