speedometer and speed sensor issue - DodgeForum.com

Go Back  DodgeForum.com > Dodge Cars > Dodge Neon
Reload this Page >

speedometer and speed sensor issue

Dodge Neon The sport compact car that took the world by storm. the Dodge Neon. Depending on the trim level you get, this sporty ride has something to offer everyone.

speedometer and speed sensor issue

  #1  
Old 07-13-2015, 12:41 PM
stonernate
stonernate is offline
Registered User
Thread Starter
Join Date: Jul 2015
Posts: 1
Default speedometer and speed sensor issue

i own a 2003 dodge neon sxt with 135k miles on it,
i had a code for the output speed sensor so i replaced it with a dealership one then my speedometer stopped working, when i press the gas the gas guage goes down to empty then i hit the brake and it goes up to half a tank, also it isnt tracking miles anymore on neither the trip or the total mileage, whats going on? i have been testing for bad grounds all over the place and cant find a bad one, unless its somehow my battery witch works fine starting and running the car. NOTE: the speed sensor code started popping up after i changed the upper motor mount, just mentioning it incase..
 

Last edited by stonernate; 07-13-2015 at 12:43 PM.
  #2  
Old 02-07-2016, 05:02 PM
ronchilders38
ronchilders38 is offline
Registered User
Join Date: Feb 2016
Posts: 1
Default 2003 Dodge Neon code 501 PLEASE HELP!!

my wife just bought the car and I have changed out the speed sensors in and out. Both of them. Speedometer still not working. It keeps engaging the check engine light and prohibiting from getting a Texas inspection sticker. I have checked all the wiring and cannot find a problem. the odometer is lit up but stuck at 142000 miles and is not registering miles. temperature gauge is working fuel tank gauge is working. I have also removed the cluster just to make sure everything look right and put it back in. All looks well. Someone please help As I am under the hood right now. If you know of something and can text me please do at 936-443-7247 Thanks
 
  #3  
Old 12-30-2018, 02:33 AM
Gary van Purser
Gary van Purser is offline
Registered User
Join Date: Dec 2018
Posts: 1
Default

have same issue but I can get my inspection I'm in Killeen tx I heard the problem is in the cluster its self and I have a few extra funny isues like my radio cuts out when I open the doors
 

Thread Tools
Search this Thread
Quick Reply: speedometer and speed sensor issue


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: