Dodge 2006 5.9L Fuel Problem! Maybe? - Page 3 - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > Dodge/Ram Diesel
Reload this Page > Dodge 2006 5.9L Fuel Problem! Maybe?
Notices
Dodge/Ram Diesel Discussions on all generations of Cummins Diesel powered Rams plus the new Eco Diesel

Dodge 2006 5.9L Fuel Problem! Maybe?

Reply

 
 
  #21  
Old 03-28-2017, 07:26 PM
p38251
p38251 is offline
Record Breaker
Join Date: Feb 2011
Location: Vanderpool Texas
Posts: 2,003
Default

You can see if the are getting power. A scanner can check pressure. Leaking. And how many mili seconds it takes to fire.
 
Reply With Quote
  #22  
Old 04-01-2017, 02:16 PM
Bosserdet's Avatar
Bosserdet
Bosserdet is offline
Registered User
Thread Starter
Join Date: Feb 2017
Posts: 14
Default

Well I have checked all the injectors for power and everyone of them is getting a signal of about 8.8 volts. It's a little hard to tell for sure the exact number but its consistent.

I called the guy I bought the injectors from and after telling him everything I have done he simply said, "Send them all back and I will ship you 6 new ones Monday". No charge!

For sure there is a God!

I am hoping for the best.
 
Reply With Quote
  #23  
Old 04-01-2017, 06:34 PM
p38251
p38251 is offline
Record Breaker
Join Date: Feb 2011
Location: Vanderpool Texas
Posts: 2,003
Default

Sweet, can't beat that. Hope that's your fix.
 
Reply With Quote
  #24  
Old 04-08-2017, 07:28 PM
Bosserdet's Avatar
Bosserdet
Bosserdet is offline
Registered User
Thread Starter
Join Date: Feb 2017
Posts: 14
Default

Well after replacing every component in the fuel systems. It turns out that one of my new injectors was bad.

I just finished replacing all 6. I did get them for free since they were under a 1 year warranty. The truck is running like its new out of the box.

p38251: Thanks for your help. Maybe this thread will bring someone else to the short answer sooner then I found it.
 
Reply With Quote
  #25  
Old 04-08-2017, 10:10 PM
p38251
p38251 is offline
Record Breaker
Join Date: Feb 2011
Location: Vanderpool Texas
Posts: 2,003
Default

Excellent. Glad you a back in business
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 12:22 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: