Tach and speedometer not working - DodgeForum.com



1995-2000 Dodge Avenger The Dodge Avenger had smooth styling in addition to solid craftmanship. To this day you can find Dodge Avenger enthusiasts proud to show of their gems.

Tach and speedometer not working

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-17-2007, 11:57 PM
brotherbluto brotherbluto is offline
Thread Starter
 
Join Date: Jan 2007
Location:
Posts: 8
Default Tach and speedometer not working

My tach, speedo, and temp gauge quit working. My fuel gauge still works. I checked all my fuses and they're all ok. Bought a used cluster off ebay and plugged it in, same thing. Any way of testing the intsrument cluster? Ideas?
Reply With Quote
  #2  
Old 01-18-2007, 07:06 AM
silvercoupe97's Avatar
silvercoupe97 silvercoupe97 is offline
Uber Moderator
Dodge Forum Moderator
 
Join Date: Jun 2005
Vehicle: 1997 Avenger ES
Location: Colorado Springs, CO
Posts: 2,305
Default RE: Tach and speedometer not working

You can find by following the circuit to test with a 1.5V battery. I've used a 9V before...but it was drained down to 5V
Are you sure you're cluster is pressed all the way in? Are you sure the plugs (behind the cluster) didn't get pushed back? They are easy enough to do so, that's why I ask. What was the last thing that you did that may have caused the issue?
Reply With Quote
  #3  
Old 01-19-2007, 02:13 AM
brotherbluto brotherbluto is offline
Thread Starter
 
Join Date: Jan 2007
Location:
Posts: 8
Default RE: Tach and speedometer not working

The car is a '96, 2.0 with a manual trans. I bought the car with a bad trans and changed it with a trans out of a '99. I drove it home and it worked fine, even the cruise worked. Other than cleaning the battery terminals, thats about all I did to it.
I guess I could start poking around to see which circuit feeds the tach and speedo and go from there. It sure seems like the cluster is being plugged in all the way and all the plugs look like they're seated right.
Reply With Quote
  #4  
Old 01-21-2007, 05:04 AM
brotherbluto brotherbluto is offline
Thread Starter
 
Join Date: Jan 2007
Location:
Posts: 8
Default RE: Tach and speedometer not working

Anyone know where i can get a wiring diagram for the engine compartment for a '96?
Reply With Quote
  #5  
Old 01-27-2007, 06:41 PM
brotherbluto brotherbluto is offline
Thread Starter
 
Join Date: Jan 2007
Location:
Posts: 8
Default RE: Tach and speedometer not working

Anyone know where i can get a wiring diagram for the engine compartment for a '96?
Reply With Quote
  #6  
Old 04-12-2007, 03:23 PM
brotherbluto brotherbluto is offline
Thread Starter
 
Join Date: Jan 2007
Location:
Posts: 8
Default RE: Tach and speedometer not working

I thought I should post that I fixed my problem. I copied a wiring diagram from the auto shop at the local highschool. The tach, speedo, and temp sensor wires run together from the engine compartment to the cluster with only one connector on the way. Located behind the radio, connection C23 was diconnected. Plugging it back in and securing it with a ziptie sovled my problem.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
speedometer and speed sensor issue stonernate Dodge Neon 1 02-07-2016 05:02 PM
EMERGENCY! AC controls/ Auto Headlights not working FakeBakn3 Dodge/Ram Diesel 4 07-16-2015 02:54 AM
turn signals stopped working but 4 ways worked BrandonBuc'em 2nd Gen Ram Tech 4 07-15-2015 02:02 PM
[3rd Gen : 96-00]: Speedometer & Fuel Gauge Failure mp2000 Dodge Caravan 0 07-07-2015 02:25 AM
tach runs in reverse tmomeik Dodge Stratus 5 07-05-2015 06:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 11:59 PM.