Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

03 Ram 1500 O2 Sensor

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-15-2007, 09:48 PM
Mikey22s Mikey22s is offline
Registered User
Garage is empty, add now
 
Join Date: May 2007
Vehicle: 2003 dodge ram 1500 quad cab 4x4
Location: Corbin Kentucky
Posts: 31
Send a message via Yahoo to Mikey22s
Default 03 Ram 1500 O2 Sensor

I havea 2003 Dodge ram 1500 4x4......the check engine light is on..... I had it scanned and it said oxygen sensor bank 1 running lean.

My truck has a little miss to it now and my gas millage has dropped from 21 to 11.9....

Where is the other 2 sensors ...1 in front of converter, and one behind it, but where are the other ones ??
Anyone else have this problem?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
__________________
Mikey Ashurst
Reply With Quote
  #2  
Old 05-16-2007, 01:14 AM
DeWalt378G DeWalt378G is offline
Record Breaker
Garage is empty, add now
 
Join Date: Jul 2005
Vehicle: '03 RCLB
Location: PA
Posts: 1,236
Default RE: 03 Ram 1500 O2 Sensor

There are only 2 o2 sensors on 03's.

wow if youwere getting 21mpg then I think I might have a problem myself......[>:]
__________________

'03 Hemi 4 work and play.System One rack,WeatherGuard saddle box,Air Ram CAI,Dynatech headers & high flow cats,Aero exhaust,Jet 180 stat,ARE Fuels 20x8.5,Custom DeWalt 3rd brake light,Custom DeWalt WeatherTech floor mats,410's,Auburn posi
Reply With Quote
  #3  
Old 05-16-2007, 03:38 PM
Mikey22s Mikey22s is offline
Registered User
Garage is empty, add now
 
Join Date: May 2007
Vehicle: 2003 dodge ram 1500 quad cab 4x4
Location: Corbin Kentucky
Posts: 31
Send a message via Yahoo to Mikey22s
Default RE: 03 Ram 1500 O2 Sensor

It was doing really well on gas... i drove it 360 miles on one tank of fuel...and some of that was interstate driving at 85 mph.........and then some highway, but ever since this sensor went out its been all to hell!
__________________
Mikey Ashurst
Reply With Quote
  #4  
Old 05-16-2007, 07:57 PM
DeWalt378G DeWalt378G is offline
Record Breaker
Garage is empty, add now
 
Join Date: Jul 2005
Vehicle: '03 RCLB
Location: PA
Posts: 1,236
Default RE: 03 Ram 1500 O2 Sensor

i got this code too and the truck ran like crap. found out the connection was loose for the downstream sensor. i unplugged it cleaned out the terminals and plugged it back in. solved. but since you are reporting a miss there might be something else going on too.
__________________

'03 Hemi 4 work and play.System One rack,WeatherGuard saddle box,Air Ram CAI,Dynatech headers & high flow cats,Aero exhaust,Jet 180 stat,ARE Fuels 20x8.5,Custom DeWalt 3rd brake light,Custom DeWalt WeatherTech floor mats,410's,Auburn posi
Reply With Quote
Old 05-16-2007, 07:57 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 04:37 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2