Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

2004 dodge ram 2500 5.7 hemi with electronic throttle control pronblems

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-21-2010, 12:40 PM
seabold seabold is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2010
Posts: 6
Default 2004 dodge ram 2500 5.7 hemi with electronic throttle control pronblems

Hi I have a 2004 dodge ram 2500 with a 5.7 Hemi, and im having trouble with the electronice throttle control light coming on and putting it into limp home mode. It doesnt stall or anything like that just goes into limp home mode I can shut the truck off and turn it back on and it will go away. I have cleaned the throttle body, and sensor on top of it. I replaced the App sensor and that didnt work eithere. I am stuck not sure what or where to check next. If you could help that would be great.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 09-21-2010, 03:24 PM
weedahoe's Avatar
weedahoe weedahoe is offline
Site Moderator
Dodge Forum Moderator
Garage is empty, add now
 
Join Date: Mar 2009
Vehicle: 04 Dodge Ram QC
Location: South GA
Posts: 18,734
TrickedOut DodgeRam Weedahoe1977
Send a message via AIM to weedahoe Send a message via MSN to weedahoe Send a message via Yahoo to weedahoe
Default

I was going to suggest that sensor but since you have already covered that, I wont bother. But I guess it could be the TB.
Reply With Quote
  #3  
Old 09-21-2010, 03:40 PM
sbsga's Avatar
sbsga sbsga is offline
Professional
Garage is empty, add now
 
Join Date: Mar 2010
Vehicle: 2002 Dodge Ram 1500 4x4, 4 Inch Fabtech Suspension Lift, 35x12.50 Kuhmo A/T's, 4.56 Gears, superchip
Location: Savannah
Posts: 228
Default

what type of spark plugs are you running? platinums can cause power spikes and cause issues in the tcm.
__________________
Reply With Quote
  #4  
Old 09-21-2010, 04:47 PM
seabold seabold is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2010
Posts: 6
Default

it only has 88,000 miles on it and I just got it like a month ago. I am asuming it still has stock plugs.
Reply With Quote
Old 09-21-2010, 04:47 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 03:02 PM.

Internet Brands, Inc.


Contact Details & Emails