Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

05 5.7 hemi slugish - underpower?!?!?

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 11-03-2013, 09:35 PM
catawissarocket catawissarocket is offline
Professional
Garage is empty, add now
 
Join Date: Mar 2010
Vehicle: 05 Dodge 1500 quad cab/5.7 hemi
Location: pa
Posts: 136
Default 05 5.7 hemi slugish - underpower?!?!?

Ok guys, im getting worried. i have an 2005 5.7 hemi and im getting an error codes p0456 - p0152 - and sometimes p0420 but the p0420 isnt showing as of lately.

the real and noticeable problem is trucks is slugish but usually until 50 ish speeds. seems like as i try to give it alittle gas it just doesnt want to pick up speed.

now if i make it shift it goes but just bogs back down if i lift from making it shift. hope its not the cat,how can i tell and is there a way to test it out at home? not sure about these codes i posted?? it has 92,600 miles and i never towed with it, only coal during winter... any help guys would be great..

hope im not hurting it, this has been on going for awhile just worse now..
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 11-03-2013, 11:18 PM
weedahoe's Avatar
weedahoe weedahoe is offline
Site Moderator
Dodge Forum Moderator
Garage is empty, add now
 
Join Date: Mar 2009
Vehicle: 04 Dodge Ram QC
Location: South GA
Posts: 18,666
TrickedOut DodgeRam Weedahoe1977
Send a message via AIM to weedahoe Send a message via MSN to weedahoe Send a message via Yahoo to weedahoe
Default

Change plugs, clean throttle body, replace air filter, use good injection cleaner, reset pcm

As for the codes, the 420 is a cat code. Could be a bad o2, could be a leak at the manifold(s) due to a crack or broken exh bolts
Reply With Quote
Old 11-03-2013, 11:18 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 07:59 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2