2005 Neon Cam position sensor problem - DodgeForum.com



Dodge Neon The sport compact car that took the world by storm. the Dodge Neon. Depending on the trim level you get, this sporty ride has something to offer everyone.

2005 Neon Cam position sensor problem

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-15-2013, 09:13 PM
BillA's Avatar
BillA BillA is offline
Registered User
Thread Starter
 
Join Date: May 2013
Posts: 2
Default 2005 Neon Cam position sensor problem

Hello to all, my 1st entry, we'll see how I do.

My Granddaughter's Neon died on her a few days ago, ran OBD on it, two codes. left bank ignition coil and Cam position sensor malfunctions.

Replaced cam sensor with new unit. That cleared the coil code but still had cam code and engine still no start. Replaced the cam sensor again-same results spark coil code cleared, cam code still there and no start. Did a spark check, coil seems to be working fine.

Anyone have a idea as to what's going on??? :-(
Reply With Quote
  #2  
Old 05-23-2013, 11:59 AM
mkmendiola's Avatar
mkmendiola mkmendiola is offline
Registered User
 
Join Date: May 2013
Vehicle: 2002 NEON R/T
Location: EUGENE, OREGON
Posts: 8
Default

Try disconnecting the negative line on the battery to help reset the ECU of that helps any.
Reply With Quote
  #3  
Old 05-23-2013, 12:00 PM
mkmendiola's Avatar
mkmendiola mkmendiola is offline
Registered User
 
Join Date: May 2013
Vehicle: 2002 NEON R/T
Location: EUGENE, OREGON
Posts: 8
Default

For about 30 seconds. Sorry I didn't specify how long.
Reply With Quote
  #4  
Old 05-26-2013, 08:39 PM
BillA's Avatar
BillA BillA is offline
Registered User
Thread Starter
 
Join Date: May 2013
Posts: 2
Default

Thanks for trying to help. Found the problem- broken timing belt. Luckily she was about 20ft from her house when it went and there appears to be no damage to the engine, just to her Mom's wallet :-)
Reply With Quote
  #5  
Old 05-27-2013, 12:56 AM
70x7 70x7 is offline
Veteran
 
Join Date: Oct 2008
Vehicle: 2002 Dodge Ram 1500 SLT QC
Location: The NEW Mexico
Posts: 313
Default

I think i remember something like this on my SRT4... i ended up having to clean everything really good for it to clear. I THINK
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 V10 Bad camshaft position sensor ? Where can I get one? 95Ram2500v10 2nd Gen Ram Tech 5 02-01-2016 12:09 AM
2004 ram hemi low speed acceleration john_2216 3rd Gen Ram Tech 6 11-09-2015 10:42 PM
'96 P300, P301, P302 Codes Crytot 1st Gen Dakota 5 07-13-2015 06:26 PM
2002 dodge neon 2.0 sohc colons3499 Dodge Neon 0 07-09-2015 04:57 PM
Nerf step board fit Q's...2014 to a 2005 rentprop1 3rd Gen Ram Tech 2 07-05-2015 11:03 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 01:17 PM.