Go Back  DodgeForum.com > Dodge Cars > Dodge Avenger > 2008 - Current Dodge Avenger
Reload this Page >

2008 Dodge Avenger 2.4 engine-- Engine lights STAYS on--NEED HELP!

2008 - Current Dodge Avenger The new Dodge Avenger gives a sporty look to the often drab mid-sized sedan class, with the possible future option of AWD and a performance engine upgrade.

2008 Dodge Avenger 2.4 engine-- Engine lights STAYS on--NEED HELP!

  #1  
Old 05-15-2013, 11:21 PM
J.B4
J.B4 is offline
Registered User
Thread Starter
Join Date: May 2013
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default 2008 Dodge Avenger 2.4 engine-- Engine lights STAYS on--NEED HELP!

Hi everyone, I have a 2008 Dodge Avenger SXT with a 2.4L engine and it has about 68,000 miles on it. Recently, the check engine light was blinking and stayed on. So I went to auto part store to have it checked and I got several codes and completely freaking out .

Codes I was given were:

P0300- Random multiple misfire detected
P0302- Cylinder 2 misfire
P0315- Crankshaft position system variation not learned
P0335- Crankshaft A malfunction
P0339- Crankshaft A circuit intermittent

So far I have replaced the crankshaft and spark plugs and the check engine light is still on. Also, I wanted to know if there's another crankshaft sensor? I could really use any help or pointers if anyone knows what else I can do. I am not the original owner and the warranty ran out on it so I am completely on my own at this point for this car while still making payments.

**UPDATE 5/16/2013- I wanted to let everyone know yesterday I also put in a engine repair in the engine after I changed the oil. Today while I was driving the check engine went off! So I'm happy, I guess it needed to work through the system.
 

Last edited by J.B4; 05-16-2013 at 09:50 AM. Reason: The check engine light went off
  #2  
Old 03-10-2014, 07:22 PM
sherirogers's Avatar
sherirogers
sherirogers is offline
Registered User
Join Date: Mar 2014
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Unhappy 09 dodge avenger engine light on

my check engine light came on and has been on i took it and gad it checked and no codes came up i have no clue what it could be... could it be because it needs a tune up badly?
 
  #3  
Old 03-11-2014, 08:48 AM
DodgeCACares's Avatar
DodgeCACares
DodgeCACares is offline
Record Breaker
Join Date: Jul 2012
Posts: 1,085
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by sherirogers View Post
my check engine light came on and has been on i took it and gad it checked and no codes came up i have no clue what it could be... could it be because it needs a tune up badly?
sherirogers,

The check engine lamp, or Malfunction Indicator Light (MIL) will come on if the onboard diagnostic system detects a condition. In some cases this light will illuminate for reasons such as a loose or missing gas cap or even poor fuel economy.

If the light stays on for several driving cycles, your Avenger may be driven, however, a trip to a servicing facility would be of benefit. If the light is flashing, immediate service is recommended.

Although your trip to the garage didn't produce any codes, was the service dept. able to provide any additional information for you?
 
  #4  
Old 03-17-2014, 12:49 PM
guapoman2000's Avatar
guapoman2000
guapoman2000 is offline
Rookie
Join Date: Nov 2009
Posts: 62
Likes: 0
Received 0 Likes on 0 Posts
Default

Just in case this issue is still a problem...

I found this discussion over at:

http://www.justanswer.com/dodge/88gr...-multiple.html
 
  #5  
Old 01-25-2017, 11:54 PM
Josh Rhea
Josh Rhea is offline
Registered User
Join Date: Jan 2017
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

What did you do to fix the problem? I changed cat today and plugs and boots still missing on 1 and 4 cyls
 
  #6  
Old 03-12-2017, 01:29 PM
poisnus
poisnus is offline
Registered User
Join Date: Mar 2017
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Hate to bust open an old thread, but did you have any luck fixing this. I have the exact same problems and I am having trouble hunting it down.
 
  #7  
Old 03-12-2017, 02:51 PM
primem
primem is offline
Record Breaker
Join Date: Apr 2013
Location: Alberta
Posts: 1,353
Likes: 0
Received 3 Likes on 3 Posts
Default

Originally Posted by poisnus View Post
Hate to bust open an old thread, but did you have any luck fixing this. I have the exact same problems and I am having trouble hunting it down.
start a new thread. post your model year, engine and the dtc that are setting.
 
  #8  
Old 02-19-2018, 07:10 PM
snookpro1
snookpro1 is offline
Registered User
Join Date: Feb 2018
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

any luck to what was wrong never saw the answer that fixed the codes
 

Thread Tools
Search this Thread
Quick Reply: 2008 Dodge Avenger 2.4 engine-- Engine lights STAYS on--NEED HELP!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: