04 RAM 2500 4x4 ABS pump wont shut off! - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Reload this Page > 04 RAM 2500 4x4 ABS pump wont shut off!
Notices
3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

04 RAM 2500 4x4 ABS pump wont shut off!

Reply

 
 
  #1  
Old 08-06-2010, 04:12 PM
04MOPAR
04MOPAR is offline
Registered User
Thread Starter
Join Date: Feb 2004
Posts: 14
Default 04 RAM 2500 4x4 ABS pump wont shut off!

SO I get in my truck and while im driving I notice the ABS light and brake dashlight is on, I can also hear the ABS pump running. I turned off the truck but the pump still runs, thought It might reset itself or something but no luck.. I had to pull the 40A fuse to get it to stop. Anyone know what could cause this?
 
Reply With Quote
  #2  
Old 08-07-2010, 02:17 PM
weedahoe's Avatar
weedahoe
weedahoe is offline
Hall Of Fame
Hall of Fame Member
Join Date: Mar 2009
Location: South GA
Posts: 19,155
Default

We would really have to look at the schematics involved with that to see what all controls it. It could be a relay with welded contacts or a bad pump.
 
Reply With Quote
  #3  
Old 08-07-2010, 07:44 PM
Gone Fishin
Gone Fishin is offline
Record Breaker
Join Date: Feb 2005
Location: Bristol, IN
Posts: 2,300
Default

I'd almost lay odds its a welded relay, the ones used in our trucks are junk
 
Reply With Quote
  #4  
Old 09-27-2010, 04:58 PM
OldTarFour
OldTarFour is offline
Registered User
Join Date: Sep 2010
Location: illinois
Posts: 1
Default

I have the same problem on my 05 2500. Did you ever come up with a solution?

Where is the relay that I should look for?
 
Reply With Quote
  #5  
Old 09-27-2010, 07:53 PM
CBR900RR19's Avatar
CBR900RR19
CBR900RR19 is offline
Professional
Join Date: Jul 2010
Location: New York
Posts: 148
Default

Originally Posted by OldTarFour View Post
I have the same problem on my 05 2500. Did you ever come up with a solution?

Where is the relay that I should look for?
I own a 2004 Dodge Ram 1500 Laramie 5.7-liter HEMI Magnum and checked the FSM looking for a relay I don't believe there is one. (Could be wrong happened once before LOL) I see two fuses 6 and 35 for the ABS module. But anyway I had this problem on my 2nd Gen so I believe your problem is the ABS Module itself. You say the pump stays running right? There is a simple ABS wizard on the site as well you could use or you could call them they are extremely helpful. But I would just pull it and send it to Module Masters. http://www.modulemaster.com/en/index.php
I sent them mine to rebuild they warranty it for 5yrs and I had it back in 3 days with new bolts all for 153.00. They were one of the best companies I have ever dealt with.


Name:  2004ABS.jpg
Views: 39
Size:  30.2 KBName:  2004ABSa.jpg
Views: 43
Size:  29.1 KB
 

Last edited by CBR900RR19; 09-27-2010 at 07:56 PM. Reason: Images were in the middle of text
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kmbaseball7
Dodge/Ram Diesel
3
07-30-2015 05:45 PM
bmw627i
Dodge Caravan
1
07-27-2015 06:41 PM
Dodgevity
2nd Gen Dakota
9
07-10-2015 05:53 PM
davebenn52
1st Gen Durango
0
07-07-2015 11:48 PM
Hemibuck
3rd Gen Durango
3
07-07-2015 10:51 AM


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Get repairs made easy
Print and online manuals

Find manuals

Featured Sponsors

All times are GMT -4. The time now is 02:14 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: