Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Reload this Page >

2004 Dodge Ram electrical problem

3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

2004 Dodge Ram electrical problem

  #11  
Old 04-27-2017, 07:00 PM
TNtech's Avatar
TNtech
TNtech is offline
Site Moderator-Dodge Tech
Dodge Forum Moderator
Join Date: Sep 2010
Location: Nashville, Tennessee
Posts: 3,706
Likes: 0
Received 1 Like on 1 Post
Default

 
  #12  
Old 04-28-2017, 08:57 AM
dss56's Avatar
dss56
dss56 is offline
Professional
Thread Starter
Join Date: Nov 2008
Location: Boston Ma
Posts: 220
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks for all the schematic info I do have the service manual and all the ones you posted.

Funny thing is I had to go out last night and my overhead temp was working again not stuck on the -40 degree. Hope it stays that way.

So its raining again in Boston today so no work on truck.

Here is still my problem.
Fuse 51 still drawing power on both sides when truck is off if fuse left in battery dead in 2-3 days.

So I put a relay in the fuse 51 to kill the fuse when truck is off.

But I loose all the settings to the radio.
I loose the function to lock my doors.
It will set the alarm but not do the doors so I have to have the truck running (fuse 51 in circuit) to lock the doors then shut the truck off.

Having the relay keeps me from pulling the fuse every night or long days of not starting.

I ordered a time delayed relay so when truck is off i still have fuse 51 in circuit for 10 minutes, will give me time to get out of truck shut it off and lock and alarm the truck.

Then auto starting will be no problems to unlock doors.

I have read believe me almost every forum and post on this fuse 51 problem and not to many people have fixed or posted the fix or what they had to do.

Yesterday I replaced the fuse box and the matching FCM with the same results.
I also took my fuse box apart and was clean as could be no corrosion or bad solder joints, all connectors looked great no broken wires no corrosion when I pulled the connectors.

I pulled the radio yesterday and still power to fuse 51.
I pulled cluster and when I pulled connector C3 it went away no power draw.
So i cut the Gray/red power to cluster wire with C3 plug back in and no power draw gone.

So what ever runs off the C3 pin 26 gray wire is the problem and when better weather comes I will trace all that runs off it.

It states fuse 51 controls the radio-under hood light don't have one and the cluster. Nothing wrong with cluster everything works all gauges.

I know other things run through the cluster and that's my next point of attack.

thanks again for the schematic post I will look them over
 

Last edited by dss56; 04-28-2017 at 09:16 AM.
  #13  
Old 08-10-2017, 01:27 AM
Hemiquad04
Hemiquad04 is offline
Registered User
Join Date: Nov 2012
Location: WA STATE
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

Any luck? Im having a 1.07A draw running thru fuse 51. I pull C3 on the back of the cluster and draw goes away. I also am having the horn continually going off. I had to pull the horn fuse and leave it out. I don't know if both problems are related or not.
 
  #14  
Old 08-10-2017, 07:46 AM
dss56's Avatar
dss56
dss56 is offline
Professional
Thread Starter
Join Date: Nov 2008
Location: Boston Ma
Posts: 220
Likes: 0
Received 0 Likes on 0 Posts
Default

I have had no luck in finding the power draw on fuse 51. I still have the relay circuit in for fuse 51, so when truck is off fuse 51 out of circuit and no dead battery in 2-3 days. I can live with that.

I'm surprised that no one chimed in on this who had this problem and got it fixed. When I was searching for this problem many people with ram trucks have had this problem. You thing Chrysler would have a bulletin repair on this.

Well good luck with your problem like mine.
 
  #15  
Old 02-24-2018, 12:14 PM
karlmich
karlmich is offline
Registered User
Join Date: Dec 2013
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default Solution?

I know this is a very old post, but if you are still on the forum, perhaps you can explain what you found. I think i am having the same issue.
 
  #16  
Old 02-24-2018, 01:06 PM
dss56's Avatar
dss56
dss56 is offline
Professional
Thread Starter
Join Date: Nov 2008
Location: Boston Ma
Posts: 220
Likes: 0
Received 0 Likes on 0 Posts
Default

I never found the problem to my battery drain. What I did was make a timed circuit of 99 minutes which is adjustable from 1-99 minutes. I did this so for 1.5 hours after I shut the truck off I will not loose any radio settings and I can control my alarm remote to lock the doors. Most times im in and out of stores within the 1.5 hours. Every time I start the truck it resets and stays at the 99 minutes until i shut truck off. Then it starts to count down and when it hits o the fuse 51 is out of circuit and will not kill my battery.
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: