ABS ESP BAS lights came and stays on - DodgeForum.com


Dodge Charger The Dodge Charger. The car that made its competitors shiver in the 60's is reborn in 2006 into a sleek sedan that can still send the competition home wimpering, the Dodge Charger.
Sponsored by:
Sponsored by:

ABS ESP BAS lights came and stays on

Reply
 
 
  #1  
Old 08-13-2011, 07:50 AM
jukka
jukka is offline
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Dubai UAE
Posts: 5
Default ABS ESP BAS lights came and stays on

Hi Guys; Need help to reset ABS ESP BAS lights on my Charger 2007 R/T.

Did not drive my car in 4 weeks and battery died. To make story short; After replacing old battery with new one (AC DELCO 94R72); ABS ESP BAS lights came on right away after I started the car.

I have tried all reset option I have been able to find on web. Including Dodge Manual ESP reset by turning wheel right/left/center then turning ignition off.
Pulling breakerís 11 and 17. Disconnecting battery for few minutes. Driving it on 60mph+ for more than 50 miles.

And about everything else I could think of.

There are no P_ _ _ _ code's on my car after I did do the test . (Turn key to On/acc/On/Acc/On)

I have done instrument cluster reset as well (just to verify it's not cluster problem) no help with that either.

Pushing ESP switch has no function at all. It stay off.

I have read on web this could be ABS sensor problem but it is unlike that because all lights came on after battery died and it was just sitting at parking garage for 4 week's

If you have any other ideas please post it here or send me direct email to [email protected]

Thanks a lot; here are few pictures to give you guys better idea about the problem. Sorry if this post is too long.

Regards
jukka







.AOLWebSuite .AOLPicturesFullSizeLink { height: 1px; width: 1px; overflow: hidden; } .AOLWebSuite a {color:blue; text-decoration: underline; cursor: pointer} .AOLWebSuite a.hsSig {cursor: default}






.AOLWebSuite .AOLPicturesFullSizeLink { height: 1px; width: 1px; overflow: hidden; } .AOLWebSuite a {color:blue; text-decoration: underline; cursor: pointer} .AOLWebSuite a.hsSig {cursor: default}


.AOLWebSuite .AOLPicturesFullSizeLink { height: 1px; width: 1px; overflow: hidden; } .AOLWebSuite a {color:blue; text-decoration: underline; cursor: pointer} .AOLWebSuite a.hsSig {cursor: default}
Reply With Quote
  #2  
Old 08-13-2011, 08:50 AM
KRZY.BMET's Avatar
KRZY.BMET
KRZY.BMET is offline
Peaceful Browser
 
Join Date: Apr 2007
Location: Miramar, Florida
Posts: 4,962
Default

Since it is an '07, when was the last time you had it in the dealer for any kind of service. I know that there has been at least 2 or 3 software upgrades since then. That might be your issue. Since the battery died, all memory was erased and the software you are running might be glitched. Most dealers are reflashing the cpu for free, some for a small fee. I would check that out. I say this because you just mentioned ALL of the resets/procedures that I would have told you about. Last thing is software. Many have had issues with this and so far almost all of them came back with fixes after visiting the dealer for a software flash. One actually had the sensor though. LOL!!!
Reply With Quote
  #3  
Old 08-13-2011, 12:05 PM
jukka
jukka is offline
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Dubai UAE
Posts: 5
Default

Thanks for the advice. I will take it to local Dodge dealer here in Dubai UAE and see what they can do about it.

I was hoping that there is some quik reset for the system that I could do myself but you mind be right about computer is out of date/data after being empty/dead for couple of weeks.

Dubai Dodge dealer's engineers are not the top engineers in the world as you can understand that fact. They are somewhat helpless when there is an issue with electrical faults and etc. I will let you gyus know what is outcome of it.
Reply With Quote
  #4  
Old 08-16-2011, 12:21 AM
jukka
jukka is offline
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Dubai UAE
Posts: 5
Default ABS ESP BAS lights UPDATE

Hi Guys; I took my car to dealer and they found out there was three msg in computer that caused these light to come and stay on.

ABS-C2206-VEHICLE CONFIGURATION MISMATCH

ABS-C121A-STEERING ANGLE SENSOR NOT INITIALIZED

ABS-C2205-STEERING ANGLE SENSOR INTERNAL (BATTERY LOW VOLTAGE)

It took about 1.5 hr for them to test/clear/test drive car at cost about 60 usd.

Everything seems to be working fine so far; I will keep my fingers crossed hoping it stays that way.

Thanks for the all the help you guys provided on my Thread and others by respondind and giving ideas how to solve them

Regards

jukka
Reply With Quote
  #5  
Old 02-29-2012, 08:14 PM
petro3
petro3 is offline
New Member
 
Join Date: Feb 2012
Posts: 1
Default

Quote:
Originally Posted by jukka View Post
Hi Guys; Need help to reset ABS ESP BAS lights on my Charger 2007 R/T.

Did not drive my car in 4 weeks and battery died. To make story short; After replacing old battery with new one (AC DELCO 94R72); ABS ESP BAS lights came on right away after I started the car.

I have tried all reset option I have been able to find on web. Including Dodge Manual ESP reset by turning wheel right/left/center then turning ignition off.
Pulling breakerís 11 and 17. Disconnecting battery for few minutes. Driving it on 60mph+ for more than 50 miles.

And about everything else I could think of.

There are no P_ _ _ _ code's on my car after I did do the test . (Turn key to On/acc/On/Acc/On)

I have done instrument cluster reset as well (just to verify it's not cluster problem) no help with that either.

Pushing ESP switch has no function at all. It stay off.

I have read on web this could be ABS sensor problem but it is unlike that because all lights came on after battery died and it was just sitting at parking garage for 4 week's

If you have any other ideas please post it here or send me direct email to [email protected]

Thanks a lot; here are few pictures to give you guys better idea about the problem. Sorry if this post is too long.

Regards
jukka







.AOLWebSuite .AOLPicturesFullSizeLink { height: 1px; width: 1px; overflow: hidden; } .AOLWebSuite a {color:blue; text-decoration: underline; cursor: pointer} .AOLWebSuite a.hsSig {cursor: default}






.AOLWebSuite .AOLPicturesFullSizeLink { height: 1px; width: 1px; overflow: hidden; } .AOLWebSuite a {color:blue; text-decoration: underline; cursor: pointer} .AOLWebSuite a.hsSig {cursor: default}


.AOLWebSuite .AOLPicturesFullSizeLink { height: 1px; width: 1px; overflow: hidden; } .AOLWebSuite a {color:blue; text-decoration: underline; cursor: pointer} .AOLWebSuite a.hsSig {cursor: default}
my wifes nitro had the same thing w/out cruise control and traction control not working also(speed sensor code came up but not active)so i figured it had to moving to be active,changed front and rear speed control sensors on the right side and fixed it
Reply With Quote
  #6  
Old 03-31-2014, 07:05 PM
bsd359's Avatar
bsd359
bsd359 is offline
Registered User
 
Join Date: Mar 2014
Posts: 1
Smile 2010 Dodge Charger SXT

Hello,
Having trouble with my BAS and ESP light stays on when car is started and driving. Sometime a tremble at brake peddle when braking. Stopping is still good so far. any suggestions thanks BSD359
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mithril
Dodge/Ram Diesel
14
10-24-2015 05:33 PM
firewagon
3rd Gen Ram Tech
3
07-16-2015 06:41 PM
zildjian3707
2nd Gen Ram Tech
9
07-15-2015 08:29 PM
markdawson
2nd Gen Ram Tech
1
07-14-2015 11:01 AM
notsofast
2nd Gen Durango
0
07-12-2015 06:37 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 05:20 AM.