Go Back  DodgeForum.com > Dodge Cars > Dodge Stealth
Reload this Page >

Stealth 93 R/T TT engine start up fail

Dodge Stealth The car that can still draw looks from auto enthusiasts everywhere, the Dodge Stealth. From the Naturally Aspirated version to the Twin Turbo, the Dodge Stealth has a little something for everyone.

Stealth 93 R/T TT engine start up fail

  #1  
Old 10-30-2011, 07:47 PM
VR-4FTW
VR-4FTW is offline
Registered User
Thread Starter
Join Date: Oct 2011
Posts: 3
Default Stealth 93 R/T TT engine start up fail

Hi,
The other day i had errands to do so I took my dodge stealth and for the first time it had problems when accelerating (just as though it ran on 4 or 5 cylinders). I went back home and the next day the car wouldn't start. When I put the starter on the "Accessory" position, the lights from the dash dim or turn off completely. When I try to start the car, the starter either does nothing or clicks a few times then nothing again. I tried to jump start the car and it didn't work either... Any ideas? :S
 
  #2  
Old 10-30-2011, 08:03 PM
Hans_GZP's Avatar
Hans_GZP
Hans_GZP is offline
Veteran
Join Date: Nov 2009
Location: Easton, PA
Posts: 279
Default

Sounds like it could just be a dead battery. The car starts doing funny things if the battery has a dead cell... even making it hard to jump start.
 
  #3  
Old 10-30-2011, 09:04 PM
VR-4FTW
VR-4FTW is offline
Registered User
Thread Starter
Join Date: Oct 2011
Posts: 3
Default

I'll try replacing my stealth battery with the brand new one from my celica and see if there's any change, but I doubt there will be, since my battery was fine before the "4 cylinder ride". What's bugging me is that all the interior lights are working fine when the key isn't in the ignition, or when in "accessory" or "on" position. I'll look into it so keep looking for updates please. Also thanks for the information

I pray for your answer to be the right one!
 

Last edited by VR-4FTW; 10-30-2011 at 09:12 PM.
  #4  
Old 10-30-2011, 10:47 PM
Hans_GZP's Avatar
Hans_GZP
Hans_GZP is offline
Veteran
Join Date: Nov 2009
Location: Easton, PA
Posts: 279
Default

I would also yank out the engine computer and check for leaking capacitors. It could also be you issue for running on 4 cylinders.
 
  #5  
Old 11-06-2011, 09:05 PM
VR-4FTW
VR-4FTW is offline
Registered User
Thread Starter
Join Date: Oct 2011
Posts: 3
Default

Definitely not a battery problem. I switched batteries and the result is the same... Now to try looking at my ECU... Sorry for the time it took, I don't have much of free time.
 

Thread Tools
Search this Thread
Quick Reply: Stealth 93 R/T TT engine start up fail


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: