08 ram problems - DodgeForum.com


Notices

Intake, Headers and Exhaust Custom Exhaust? New Headers? Need Opinions on Intakes? Discuss making your ride breathe better here.

08 ram problems

Reply
 
 
  #1  
Old 01-21-2008, 01:48 AM
rebwie
rebwie is offline
Registered User
Thread Starter
 
Join Date: Jan 2008
Location:
Posts: 23
Default 08 ram problems

my 04 dodge hemi was stolen& TOTALED,around thanksgiving.sooooo i replaced it with about same truck model and options ,but in a 2008 === so far i hate this truck ,wish i had my 04 back !!!!! the rpm's are around 1500-2000 at start up (my old truck never did this)dealer said ,because it was cold ,then they said break in period ,,finally i got mad because it would do it after driving around all day ,shutting it off for minute and then restarting ,and when it was 45 degrees out !! then they took it in shop and said it needed a upgrade ,they did it and it did not work so now they say dodge is sending them another up grade ????? it's BRAND NEW my old truck never went into shop ,,,,,,,also this truck has low take off you really need to give gas hard or else it sputters ,,it also has a much stiffer ride then the 04 --- interior poppinp

ANY SUGGESTION ,,,ANY ONE ELSE HAVE A 08 WITH PROBLEMS

the problems so far 1 month later are = intrior light in back seat worked for a day or two ,when you'd open doors .... now it does not /// but funny thing is you can manually turn it on .

Reply With Quote
  #2  
Old 03-16-2008, 09:49 PM
Az2500Cummins08
Az2500Cummins08 is offline
 
Join Date: Feb 2008
Location:
Posts: 1,015
Default RE: 08 ram problems

Friend of mine has an 08 1500 hemi, when he puts it to the floor the transmission doesnt downshift, it stays in the current gear and slowly climbs up to speed.
Reply With Quote
  #3  
Old 04-14-2008, 11:17 PM
BigMC_81
BigMC_81 is offline
 
Join Date: Oct 2007
Location:
Posts: 5
Default RE: 08 ram problems

I know what you mean about the RPM's being up there...I took mine back teh next day because I thought something was wrong. The mechanic said it was the way the electronic ignition was and that they all started out high like that. If you let it sit for about 45-60 seconds, it goes down to a normal idle. Is that the case with yours as well? Other than that, no issues yet. I have about 4400 miles on mine and I bought it in October 07.
Reply With Quote
  #4  
Old 07-30-2008, 10:14 PM
sunburst08's Avatar
sunburst08
sunburst08 is offline
Rookie
 
Join Date: Jul 2008
Location: south texas
Posts: 75
Default RE: 08 ram problems

i hope this helps some, on my 04 focus svt the svt group told me that it did this due to emissions, that it needed to too get the cats up to proper operating temps, my 08 hemi does this and i just figured it's normal. hope this helps
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dmodracer3
2nd Gen Ram Tech
7
10-04-2015 01:28 PM
Strocket
1st Gen Durango
3
08-02-2015 05:20 PM
redsaber
3rd Gen Ram Tech
2
07-19-2015 11:19 PM
camijack63
2nd Gen Dakota
1
07-18-2015 04:33 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 02:54 AM.