Spirit v6 missing - DodgeForum.com


Notices

K-Cars The generation of cars that will forever live in infamy. The glorious K-car.

Spirit v6 missing

Reply
 
 
  #1  
Old 07-28-2016, 01:47 PM
93spirit
93spirit is offline
Registered User
Thread Starter
 
Join Date: Jul 2016
Posts: 7
Default Spirit v6 missing

hello

my spirit seems like it misses on acceleration. Ive changed out the fuel filter, plugs wires, plugs, dist cap, cleaned out the throttle body you name it. just cannot figure out why its running crappy on accelerate. I checked the engine codes and got a 31 which says bad purge solenoid but I dont think thats it because I didnt have that before when it was missing. could be wrong though. and if it is does anyone know where it is located and how to test it?

Thank you.
Reply With Quote
  #2  
Old 07-28-2016, 01:51 PM
93spirit
93spirit is offline
Registered User
Thread Starter
 
Join Date: Jul 2016
Posts: 7
Default

oh and it is really intermittent. seems to do it more in the morning but did it while on the interstate today and was jerking
Reply With Quote
  #3  
Old 08-10-2016, 07:16 AM
smokesxt's Avatar
smokesxt
smokesxt is offline
All Star
 
Join Date: Aug 2009
Location: poynette WI
Posts: 944
Default

Check your MAP sensor connector. My car would do this and it was a bad connection at the MAP.
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chickenwing
Dodge/Ram Diesel
4
03-13-2016 08:38 AM
kylemac
3rd Gen Ram Tech
7
02-28-2016 10:44 AM
Rafa
Dodge Dakota
6
10-21-2008 11:39 AM
Rafa
Dodge Dakota
3
04-05-2004 12:12 AM
jrwpmw
Dodge Ram
1
01-03-2004 07:54 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 10:23 AM.