Need help - DodgeForum.com

Notices
Mid West IL, IN, IA, MI, MN, MO, OH, WI

Need help

Reply

 
 
  #1  
Old 03-18-2017, 08:05 PM
Dodhe0719
Dodhe0719 is offline
Registered User
Thread Starter
Join Date: Mar 2017
Posts: 3
Default Need help

I've got a 2000 cummins and recently when I bought it there was a leak in my oil return line. I got it fixed and recently when I accelerate it builds boost then seems like it loses it all. It sounds more like air escaping. It's hard to explain. Any help would be appreciated
 
Reply With Quote
  #2  
Old 03-19-2017, 10:22 AM
jkeaton's Avatar
jkeaton
jkeaton is offline
Site Moderator
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 20,023
Default

What vehicle and what year? We are not mind readers.
 
Reply With Quote
  #3  
Old 03-20-2017, 09:38 PM
Dodhe0719
Dodhe0719 is offline
Registered User
Thread Starter
Join Date: Mar 2017
Posts: 3
Default

Well I put on my post it's a 2000 dodge cummins 2500 ...
 
Reply With Quote
  #4  
Old 03-20-2017, 10:19 PM
jkeaton's Avatar
jkeaton
jkeaton is offline
Site Moderator
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 20,023
Default

I obviously can't read. Lol. My bad.
 
Reply With Quote
  #5  
Old 03-20-2017, 10:20 PM
Dodhe0719
Dodhe0719 is offline
Registered User
Thread Starter
Join Date: Mar 2017
Posts: 3
Default

lol that's okay
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 06:39 PM.