Ramcharger, Trailduster & Power Wagon Grrrr!! Tough Trucks! The Dodge Ramcharger and Plymouth Trailduster were full size SUV's that had good looks and brute strength. The Dodge Power Wagon was comparable to them in toughness, but came in pickup truck form only.

Ramcharger Wont Start

  #1  
Old 05-01-2018, 10:52 PM
Dmosk
Dmosk is offline
Registered User
Thread Starter
Join Date: May 2018
Location: Scranton PA
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Ramcharger Wont Start

New here and need some help. I have a 84 Ramcharger that as the title suggests just wont start. it was originally a Royal 150LE with a 318 4wd only. She was swapped with a 360 out of a 79 Trail Duster and part time 4wd with a Dana44 in front by the previous owner who is a mechanic by trade. She hasn't move or ran in 9 years when I bought her. I have replaced and installed the following:

-New Battery (Redid ground and positive terminal)
-New Cap, Rotor, Plugs and Wires
-Edelbrock 1406 4BBL
-Electric Fuel Pump (tried running OEM style mechanical and it wasn't priming)
-New Fuel Filter (Both before pump and between pump and carb)
-New Ignition Coil
-New Ignition Control Module (4pin OEM)
-New Starter
-New Ballast Resister
-EGR Delete (Emissions not required where I live and the old one was shot plus was hitting the linkage on new Carb. Welded up the old one on bottom cup off top half and bolted in place with gasket.)

So at first she wasn't cranking at all, discovered it was a bad fusable link patched that out and the starter turns just fine now. Tested the plugs and determined I had no spark, changed the Cap, Rotor and plugs and still nothing, changed out the aged Acell Super coil for a BWD coil and changed the resistor at the same time. Tried to trace the Ignition system to find and issues and found the factory ignition control module had melted most of the resin that seals the back all over the firewall so replaced that. This gave her spark Checked the timing and found she was 180 Out, timed her to 0deg TDC just to try and get a baseline and have tried to rotate the cap to get it to time right and nothing. Realized the Fuel pump wasnt supplying Fuel changed it with a new OEM style pump and she still wasn't moving so I installed Holley Electric pump and now she has fuel to the Carb, I tested compression and after a few drops on each cyl she had good numbers across the board. I double checked firing order (Both in Factory service manual as well as its cast onto the top of the factory Intake manifold and its correct. So now with Fuel, Air, Spark and Compression this is the problem: She wont start. She will occasionally backfire out the Carb, she will crank via starter around 3 or 4 cycles before burping air out the top and maybe every second or so time she'll have a small fireball also out the top but that's about it, she was doing the same before I found she was 180 out and addressed that only she would try to start only to backfire out the exhaust. I am at a complete loss here, every system I check is functional and everything is working independently bot combines she just refuses to start. If anyone has any ideas please help me find what I'm missing.
 
  #2  
Old 05-02-2018, 06:41 AM
Moparite's Avatar
Moparite
Moparite is offline
Champion
Join Date: Feb 2015
Posts: 3,067
Likes: 0
Received 5 Likes on 4 Posts
Default

She hasn't move or ran in 9 years
Did you drain the tank and put in fresh gas?
 
  #3  
Old 05-02-2018, 11:02 AM
Dmosk
Dmosk is offline
Registered User
Thread Starter
Join Date: May 2018
Location: Scranton PA
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Moparite, i dropped the tank as low as the pump i had could then added about 10 gallons of gas with stabil.
 
  #4  
Old 05-02-2018, 06:33 PM
Moparite's Avatar
Moparite
Moparite is offline
Champion
Join Date: Feb 2015
Posts: 3,067
Likes: 0
Received 5 Likes on 4 Posts
Default

I would have left out the stabil, I used it once and the gas that didn't have it worked but the gas with it wouldn't start anything. Last time i wasted my money on that crap. It was put in in the fall and tried to use it in the spring. Had to drain the tank and put in straight gas. Pour a little straight gas down the carb and see what happens. Do you have the choke and throttle set up right? Check the timing manually, You may have it to far advanced. It shouldn't backfire out the carb.
 
  #5  
Old 05-08-2018, 05:35 PM
Daves69
Daves69 is offline
Veteran
Join Date: Dec 2012
Location: Chi - west
Posts: 316
Likes: 0
Received 0 Likes on 0 Posts
Default

I use Stabil every winter in my boat layup in October. Starts right up in April. Good stuff. Opened the Holley 2300 carb up to clean out any muck left by todays 87 octane gas after 8 years and it was immaculate.

 

Thread Tools
Search this Thread
Quick Reply: Ramcharger Wont Start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: