Avenger 2nd Gen Do It Yourself information - Page 2 - DodgeForum.com

Go Back  DodgeForum.com > Dodge Cars > Dodge Avenger > 2008 - Current Dodge Avenger
Reload this Page > Avenger 2nd Gen Do It Yourself information
Notices
2008 - Current Dodge Avenger The new Dodge Avenger gives a sporty look to the often drab mid-sized sedan class, with the possible future option of AWD and a performance engine upgrade.

Avenger 2nd Gen Do It Yourself information

Closed Thread

 
 
  #11  
Old 05-30-2011, 01:42 AM
steak59
steak59 is offline
Record Breaker
Join Date: Dec 2010
Posts: 1,878
Default

Originally Posted by guapoman2000 View Post
Thank you! Will check switch as I don't believe my Brake Fluid level is low enough to cause the senor to trip but, if so, it must be a really sensitive sensor!

Carlos
Well, The fluid sensor has a Float Bow like ur toilet in the fluid bottle, with a Magnet attach to it. if the fluid is "kinda low", it'll swing low enuff to trip the switch when you go over bump or going uphill/downhill.

when you replace it, you replace the outside sensor. The one with 2 wires going into it.
 

Last edited by steak59; 05-30-2011 at 01:45 AM.
  #12  
Old 05-30-2011, 01:46 AM
guapoman2000's Avatar
guapoman2000
guapoman2000 is offline
Amateur
Join Date: Nov 2009
Posts: 27
Default

Originally Posted by steak59 View Post
Well, The fluid sensor has a Float Bow like ur toilet in the fluid bottle, with a Magnet attach to it. if the fluid is "kinda low", it'll swing low enuff to trip the switch when you go over bump or going uphill/downhill.
Yeah, I know and thanks.

I will check in the morning for the brake fluid level.

Bumps are not causing any chime / BRAKE Light to go ON.

It is only in tight turns and going down hill in a highway exit ramp.

I know which one causes it and it is like clock work!!!

Glad to learn that I do not need Brakes!!!

Thanks again!
Carlos
 
  #13  
Old 06-05-2011, 12:24 PM
guapoman2000's Avatar
guapoman2000
guapoman2000 is offline
Amateur
Join Date: Nov 2009
Posts: 27
Default Seems like the Brake Fluid was low!

Originally Posted by steak59 View Post
Well, The fluid sensor has a Float Bow like ur toilet in the fluid bottle, with a Magnet attach to it. if the fluid is "kinda low", it'll swing low enuff to trip the switch when you go over bump or going uphill/downhill.

when you replace it, you replace the outside sensor. The one with 2 wires going into it.
Okay good people!

During a Trip to Miami, Florida and West Palm Beach from Orlando, Florida this past weekend (Saturday, June 4th, 2011), I finally stopped into a Miami, Florida DISCOUNT-ADVANCE AUTO PARTS and they connected their Computer CODE hand held device and all was okay and no ugly codes were detected. They performed the read twice to make sure the procedure was done correctly.

I bought one pint of quality Synthetic DOT3 Brake Fluid and the AUTO Parts employee topped off the Brake reservoir. We noticed that it took right around 3oz. to Top-Off the reservoir.

Once back on the road visiting family, I happen to find a expressway exit ramp that forced the car in a tight Right hand turn and NO chime NOR "BRAKE" warning was noticed on the DASH!

Seems like this solved the issue!

Thanks!
Carlos
 
  #14  
Old 09-28-2012, 10:03 AM
Derson59
Derson59 is offline
Registered User
Join Date: Sep 2012
Location: Richfield,MN
Posts: 7
Default

I have that issue too. I am about to go do that as well.
 
  #15  
Old 09-28-2012, 07:42 PM
steak59
steak59 is offline
Record Breaker
Join Date: Dec 2010
Posts: 1,878
Default

Make sure you get your brake pad inspected before you do that. Most of the time is because your brake pad linings are low. The brake reservoir lines are designed to go to LOW when your brake linings are worn. You top off the bottle, you could be just masking the problems.
 
  #16  
Old 10-27-2012, 01:15 PM
Gregory Biamby
Gregory Biamby is offline
Registered User
Join Date: Oct 2012
Posts: 1
Default

Does anyone know how to fix a daylight running lights problem my running lights dont go off after I start the car and the signals and high beams and low beams and wiper dont work?
 
  #17  
Old 02-03-2015, 12:37 PM
stevemcc0322
stevemcc0322 is offline
Registered User
Join Date: Jan 2015
Posts: 12
Default

I USED 2012 DODGE AVENGER 2.4L AS OEM MODEL. I USED 2012 DODGE AVENGER RT 3.6L AS THE RT BASE LINE AND THE 2012 CHRYSLER 200 TOURING 3.6L AS THE OTHER SOURCE. KEEP THAT IN MIND WHEN READING THIS.

please also note that none of the sources that I have used has been able to provide thickness of the parts. I can fill in what I know but that is it.. if you know the others then please update

Front sway bars :
4670526AA Chrysler 200 touring…
(68080525AA RT same part number as SXT)

Rear sway bar:
4670519AA Touring Suspension sway bar (fits all cars listed)
68089521AA Sport Suspension sway bar (fits all cars listed) ******

Bushings rear:
OEM 5272649AC RT & avenger
5168021AA for 200 touring

Bushings front: 5168245AA for 200 // sxt // and RT

Front end links (OEM 5174185AC same on all cars.. 10.5 inches long and 8 MM thick.

Rear end links (OEM 5174245AD same on all cars) 3.25 inches long and 8 MM thick

Adjustable rear upper control arms rear : SPC 67018 will work on all cars listed

Camber kit front SPC Performance EZ Cams 81260 will work on all cars listed
 
  #18  
Old 11-30-2015, 11:41 PM
Libby's Avatar
Libby
Libby is offline
Registered User
Join Date: Nov 2015
Posts: 1
Default changing gear **** light in console on 2011 avenger

just bought t from private party and found it had no light in the shifter panel only the one of the dash

any assistance on how to change it and the bulb info would be greatly appreciately
 
  #19  
Old 12-02-2015, 12:08 PM
jkeaton's Avatar
jkeaton
jkeaton is offline
Site Moderator
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 20,040
Default

Originally Posted by Libby View Post
just bought t from private party and found it had no light in the shifter panel only the one of the dash

any assistance on how to change it and the bulb info would be greatly appreciately

You should start your own thread.
 
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Micah Vanella
Dodge Caravan
6
04-13-2016 01:21 AM
usmc1811
Brand News, Concepts & Rumors
5
10-05-2015 12:33 PM
wilcoxjmm
1995-2000 Dodge Avenger
6
10-04-2015 10:47 PM
Partsman41953
1995-2000 Dodge Avenger
1
10-04-2015 09:22 PM
Jon-Prone
2008 - Current Dodge Avenger
0
09-20-2015 08:19 PM


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 06:42 AM.