Electronic Throttle Control Light/horse power loss - Page 2 - DodgeForum.com

Go Back  DodgeForum.com > Dodge Cars > Dodge Avenger > 2008 - Current Dodge Avenger
Reload this Page > Electronic Throttle Control Light/horse power loss
Notices
2008 - Current Dodge Avenger The new Dodge Avenger gives a sporty look to the often drab mid-sized sedan class, with the possible future option of AWD and a performance engine upgrade.

Electronic Throttle Control Light/horse power loss

Reply

 
 
  #11  
Old 09-06-2012, 03:51 PM
tommy1987
tommy1987 is offline
Registered User
Join Date: Sep 2012
Posts: 2
Default

Listen everyone i know what the problem is
 
Reply With Quote
  #12  
Old 09-06-2012, 03:53 PM
tommy1987
tommy1987 is offline
Registered User
Join Date: Sep 2012
Posts: 2
Default

The problem is the electrnic throttle body. Replace it with a brand new one ... U can get one on ebay for 188$ if u do not replace it you can blow your tranny... It just happned to me.. I contacted some friends i have and we replaced the tranny and it still did it... There is no throttle positioning sensor it's built into the throttle body.. Replace throttle body asap or you will be needing a new tranny.. Do not drive car until fixed.. Thanks
tom
parts specialist for pinellas county florida
 
Reply With Quote
  #13  
Old 12-14-2012, 11:34 AM
Jae Elle
Jae Elle is offline
New Member
Join Date: Dec 2012
Posts: 1
Default

Thanks tommy1987 that was very helpful. I have a 2008 Dodge Avenger with electronic throttle issues. Please report this problem because recalls go off your vin not the model. Just because one person got a refund doesn't mean you will, but if everyone reports this problem we could get closer to investigating all vin's with this problem and keep all receipts. Please report problems to both #'s 1800-992-1997 and 1888-327-4236
 
Reply With Quote
  #14  
Old 11-26-2013, 11:45 AM
jamesinsc's Avatar
jamesinsc
jamesinsc is offline
Registered User
Join Date: Nov 2013
Posts: 3
Default Glad I did a google search

I just bought a 2013 Avenger that just turned 1000 miles and last night the ETC light came on. I'm waiting on the dealership to call back now.
I'll update later.

Knew Ishould have bought another Camry.
 
Reply With Quote
  #15  
Old 12-11-2013, 04:50 PM
paula.kula
paula.kula is offline
Registered User
Join Date: Dec 2013
Posts: 1
Default

Live in Iowa 2011 Chysler200 was told Ice intrusion throttle body ruined part ordering new "one" take 1 to up to a week to replace. Asked how it got ice in it or "froze" as it's kept in the garage and this started before it became cold here. Throttle light on wouldn't accelerate. Tech said he didn't know what caused it reading all post and not happy with this problem starting called 8009221997 reported to chrysler so I have a case # in case this doesn't fix it. Dealership telling me it will be covered under warranty.
 
Reply With Quote
  #16  
Old 12-11-2013, 05:19 PM
TNtech's Avatar
TNtech
TNtech is offline
Site Moderator-Dodge Tech
Dodge Forum Moderator
Join Date: Sep 2010
Location: Nashville, Tennessee
Posts: 3,421
Default

Originally Posted by paula.kula View Post
reading all post and not happy with this problem starting called 8009221997 reported to chrysler so I have a case # in case this doesn't fix it.
Why in the world would you call and open a case because you read something on the internet. Parts fail sometimes. How is 16 posts since Jan 2010 described as "all these posts"? They're fixing your car under warranty. Why are some of you just hell-bent on escalating things that have no need to be escalated. All you do is clog up the system for people who have real issues....good lord!
 

Last edited by TNtech; 12-11-2013 at 05:22 PM.
Reply With Quote
  #17  
Old 12-12-2013, 07:41 AM
jamesinsc's Avatar
jamesinsc
jamesinsc is offline
Registered User
Join Date: Nov 2013
Posts: 3
Default

Originally Posted by jamesinsc View Post
I just bought a 2013 Avenger that just turned 1000 miles and last night the ETC light came on. I'm waiting on the dealership to call back now.
I'll update later.

Knew I should have bought another Camry.
Light went out at the dealership when they looked at it the next day and the computer showed no errors. If a new car can throw a sensor and loose power and then show nothing wrong has happened then there is a problem in the system somewhere.
And I did have to call the 800 number since after multiple messages the dealership would not call back.
 
Reply With Quote
  #18  
Old 12-12-2013, 10:06 AM
DodgeCares's Avatar
DodgeCares
DodgeCares is offline
Record Breaker
Join Date: Jul 2011
Location: Mopar HQ
Posts: 2,482
Default

Originally Posted by paula.kula View Post
Live in Iowa 2011 Chysler200 was told Ice intrusion throttle body ruined part ordering new "one" take 1 to up to a week to replace. Asked how it got ice in it or "froze" as it's kept in the garage and this started before it became cold here. Throttle light on wouldn't accelerate. Tech said he didn't know what caused it reading all post and not happy with this problem starting called 8009221997 reported to chrysler so I have a case # in case this doesn't fix it. Dealership telling me it will be covered under warranty.
Foreign material (ice or dirt) on the Throttle Plate or in the bore can cause the Throttle Plate to stick or "freeze."
 
Reply With Quote
  #19  
Old 12-12-2013, 10:08 AM
DodgeCares's Avatar
DodgeCares
DodgeCares is offline
Record Breaker
Join Date: Jul 2011
Location: Mopar HQ
Posts: 2,482
Default

Originally Posted by jamesinsc View Post
Light went out at the dealership when they looked at it the next day and the computer showed no errors. If a new car can throw a sensor and loose power and then show nothing wrong has happened then there is a problem in the system somewhere.
And I did have to call the 800 number since after multiple messages the dealership would not call back.
Was this resolved? Or is it an intermittent problem that could not be diagnosed?
 
Reply With Quote
  #20  
Old 12-12-2013, 10:12 AM
TNtech's Avatar
TNtech
TNtech is offline
Site Moderator-Dodge Tech
Dodge Forum Moderator
Join Date: Sep 2010
Location: Nashville, Tennessee
Posts: 3,421
Default

Originally Posted by jamesinsc View Post
And I did have to call the 800 number since after multiple messages the dealership would not call back.
Well, thanks for finishing the story then. In that case, burn the 1800 number up.
 
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Tim Hutson
Dodge/Ram Diesel
2
07-19-2015 09:38 PM
Crytot
1st Gen Dakota
5
07-13-2015 05:26 PM
kassie78
Dodge Caravan
0
07-06-2015 10:23 PM
ydde1937
Dodge Caravan
0
07-06-2015 09:00 PM
03Ram5.7
3rd Gen RAM general discussion/NON-tech
5
07-06-2015 05:41 PM


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 08:50 PM.