Beeping/dinging and dash lights flickering - DodgeForum.com


Notices

2008 - Current Dodge Avenger The new Dodge Avenger gives a sporty look to the often drab mid-sized sedan class, with the possible future option of AWD and a performance engine upgrade.

Beeping/dinging and dash lights flickering

Reply
 
 
  #1  
Old 02-28-2017, 06:13 PM
Ashley Langford Agey
Ashley Langford Agey is offline
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 4
Default Beeping/dinging and dash lights flickering

I have a 2012 Dodge Avenger and it has been beeping/dinging and the lights on the dash would flash. It's the same sound that goes off when you have low fuel or need an oil change. There have been times where it would just beep and that was it. Last 2 days it has done it more frequently. This morning it did it multiple times and each time my rpms would drop then go right back up. Anyone have any similar issues and what it was? My dad hooked it up and it's not throwing any codes, he can't dubs any loose ground wires. I don't have the money to take it to the dealer. Please help
Reply With Quote
  #2  
Old 03-01-2017, 08:44 AM
jkeaton's Avatar
jkeaton
jkeaton is offline
Site Moderator
 
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 19,652
Default

Have the battery and alternator checked.
Reply With Quote
  #3  
Old 03-01-2017, 02:32 PM
Ashley Langford Agey
Ashley Langford Agey is offline
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 4
Default

We had both checked and they came back fine. My dad had a spare battery he put in my car to see if that helps. I have some errands to run today so I'm going to see if it continues to happen. Will update.
Reply With Quote
  #4  
Old 03-01-2017, 02:43 PM
jkeaton's Avatar
jkeaton
jkeaton is offline
Site Moderator
 
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 19,652
Default

Also make sure the battery connections are nice and tight. Could also be a connector coming loose on the back of the instrument cluster.
Reply With Quote
  #5  
Old 03-01-2017, 07:31 PM
Ashley Langford Agey
Ashley Langford Agey is offline
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 4
Default

Yea he checked all connections. My car wouldn't start this afternoon after we just had it running. So my husband had a guy he used to work with come jump start it and it took 3 jump starts to get it to our house and we were just a few blocks away. So he is saying alternator.
Reply With Quote
  #6  
Old 03-02-2017, 02:33 AM
Ashley Langford Agey
Ashley Langford Agey is offline
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 4
Default

We got the new alternator put on and car was still doing the same thing. We are now thinking maybe the battery my dad had isn't holding a charge? So tomorrow I will use my husbands truck to take up my old battery and alternator up and get tested. Any other ideas/options that it could be?
Reply With Quote
  #7  
Old 03-02-2017, 07:37 AM
jkeaton's Avatar
jkeaton
jkeaton is offline
Site Moderator
 
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 19,652
Default

As my first response stated, that's where you should start.
Reply With Quote
  #8  
Old 03-05-2017, 02:54 PM
Brannigan03
Brannigan03 is offline
Registered User
 
Join Date: Jan 2017
Location: Millville, MA
Posts: 4
Default

Had a similar situation but my car was throwing all kinds of codes. Ended up being a loose ground under the hood to the left of the jump block. You have to move some wires to see it though. Luckily my '12 was under warranty so the dealer had to find it.
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 01:11 AM.