hazards, brake lights, turn signals not working - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Reload this Page >

hazards, brake lights, turn signals not working

2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

hazards, brake lights, turn signals not working

  #1  
Old 07-01-2008, 07:40 AM
onemoreproject4me
onemoreproject4me is offline
Thread Starter
Join Date: Jul 2008
Location:
Posts: 14
Default hazards, brake lights, turn signals not working

Greetings,

I am new to the forum and I just recently bought my first Dodge. It is a 1995 Dodge Ram 1500 4x2 with a 5.2L V8 and automatic transmission. I think I got a truck with more issues then sports illustrated... ugh... but it was cheap and has a newer engine in it.

Well my girlfriend who was following me home after I purchased the truck noticed that I didn't have any brake lights. I asked her if she saw my turning signals which she didn't see either. I turned the turn signals on and none of the lights came on (front or back), I tried the hazards and none of the lights came on or blinked. I turned the lights on and the regular lights, head lights and tail lights work fine.

The truck has an aftermarket wiring for a trailer by the bumper.
-I took the rear taillights out and checked them but the bulbs were fine. Didn't appear blown.
-I then checked the wiring and the taillight sockets which were also fine.
-I checked the trailer wiring from the rear lights and it was connected properly with no exposed wires.
-i checked all the fuses inside the cabwhich were fine.

There was no clicking sound when iturned on the turn signals or the flashers and the indicators on the dash didn't light up either.

What should I do next? any help would be greatly appreciated.

 
  #2  
Old 07-01-2008, 09:31 AM
Mowhawk's Avatar
Mowhawk
Mowhawk is offline
Record Breaker
Join Date: Oct 2007
Location: Allentown, PA
Posts: 1,680
Default RE: hazards, brake lights, turn signals not working

Sounds like you could have a few bad switches.
 
  #3  
Old 07-01-2008, 11:00 AM
tom01973
tom01973 is offline
Rookie
Join Date: Apr 2008
Posts: 74
Default RE: hazards, brake lights, turn signals not working

unplug the trailer wiring and plug the tail lights back in.maybe a short in the wiring to the brake lights.
 
  #4  
Old 07-01-2008, 03:00 PM
onemoreproject4me
onemoreproject4me is offline
Thread Starter
Join Date: Jul 2008
Location:
Posts: 14
Default RE: hazards, brake lights, turn signals not working

The trailer wiring is not a plug in type. They spliced it in after the connector. (basically they did it the cheap way with a universal type kit)
 
  #5  
Old 07-01-2008, 03:02 PM
onemoreproject4me
onemoreproject4me is offline
Thread Starter
Join Date: Jul 2008
Location:
Posts: 14
Default RE: hazards, brake lights, turn signals not working

ORIGINAL: Mowhawk

Sounds like you could have a few bad switches.
Which switches could be bad? Is there a way to test them?
 
  #6  
Old 07-02-2008, 01:53 AM
tom01973
tom01973 is offline
Rookie
Join Date: Apr 2008
Posts: 74
Default RE: hazards, brake lights, turn signals not working

ok grab a test light and check for power at the splices for the trailer lights.if no power there then time to check the wiring in the cab under the dash.could be a wire pulled out of the connector for the turn signal switch.
 
  #7  
Old 07-02-2008, 06:36 PM
onemoreproject4me
onemoreproject4me is offline
Thread Starter
Join Date: Jul 2008
Location:
Posts: 14
Default RE: hazards, brake lights, turn signals not working

i replaced both flashers today and the bulbs. Going for elimination now. The bulbs on the middle brake light up high now work so i know it isn't the brake light switch (atleast for the brake purpose) Turn signals or flashers still dont' work.

I pulled apart the dash and there wasno wires out of place going to the fuse box.

I think I am going to get a turn signal or multiswitch and replace that next.
 

Thread Tools
Search this Thread
Quick Reply: hazards, brake lights, turn signals not working


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: