help!! I'm confused, what's wrong with my truck? - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Reload this Page > help!! I'm confused, what's wrong with my truck?
Notices
2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

help!! I'm confused, what's wrong with my truck?

Reply

 
 
  #1  
Old 06-10-2011, 06:07 PM
cowgirljenn
cowgirljenn is offline
Registered User
Thread Starter
Join Date: Apr 2011
Posts: 5
Unhappy help!! I'm confused, what's wrong with my truck?

i had replaced the alternator in my truck and the serpentine belt.... as soon as i started right after i got the belt on it it squeals bad and can smell burning rubber.. the belt is really tight and as soon as we start the truck i notice the tensioner will move a little bit... does anyone have any suggestions as to what is wrong with it this time??? PLEASE HELP I WANT TO DRIVE MY TRUCK
 
Attached Thumbnails
help!! I'm confused, what's wrong with my truck?-photo-0056-640x480-635x425-635x425-.jpg  
Reply With Quote
  #2  
Old 06-10-2011, 06:20 PM
drewactual's Avatar
drewactual
drewactual is offline
Champion
Join Date: Aug 2010
Location: Cape Carteret NC
Posts: 2,697
Default

are you certain you have it routed correctly? are you sure you have the right grooved belt?

you may need to start it BRIEFLY with the hood up and someone watching... just long enough to inspect each pulley and make sure they're rolling..

when what is happening to you happens, it's been my experience I routed teh belt wrong, or one of the pulleys is frozen..
 
Reply With Quote
  #3  
Old 06-10-2011, 06:21 PM
dodgeram07's Avatar
dodgeram07
dodgeram07 is offline
Champion
Join Date: Mar 2008
Location: ohio
Posts: 3,363
Default

is the alternator spings free lee? also are the other?
 
Reply With Quote
  #4  
Old 06-10-2011, 06:27 PM
jasonw's Avatar
jasonw
jasonw is offline
Site Moderator
Dodge Forum Moderator
Join Date: Jan 2008
Location: Sioux Falls, SD
Posts: 8,376
Default

Since this is a tech question, moved it to the main section. Should get more help that way.
 
Reply With Quote
  #5  
Old 06-10-2011, 08:35 PM
97tn4x4
97tn4x4 is offline
Record Breaker
Join Date: Mar 2009
Location: Memphis, TN
Posts: 1,814
Default

The tensioner will move some, that's ok. I'm with everyone else, check the routing of the belt. Pull it back off and check each pulley too while you're at it.
 
Reply With Quote
  #6  
Old 06-11-2011, 01:31 AM
Sheriff420's Avatar
Sheriff420
Sheriff420 is offline
Grand Champion
Join Date: Apr 2008
Location: Lee County, North Carolina
Posts: 6,968
Default

Double check the part number for the belt or match it to the old one to make sure it's the right belt.
 
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Khris1994
2nd Gen Ram Tech
121
10-24-2015 02:47 PM
SteveTangential
1st Gen Ram Tech
4
09-10-2015 10:38 AM
JoshuaYsassi
2nd Gen Ram Tech
63
07-24-2015 12:14 AM
tmomeik
Dodge Stratus
5
07-05-2015 05:16 PM
kenm78
4th Gen Ram Tech
1
07-05-2015 02:05 PM

Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 04:44 AM.