No 3-4 shift - DodgeForum.com


Notices

2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

No 3-4 shift

Reply
 
 
  #1  
Old 05-18-2017, 04:17 PM
Jason.tiger
Jason.tiger is offline
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 9
Default No 3-4 shift

97 Dodge Ram 5.2L 1500 4wd won't shift from 3-4. Changed tcc solenoid,and the sensor,solenoid,filter and fluid in transmission pan. Pretty much did everything except adjust bands. Has P0783 code. Any help is much appreciated.
Reply With Quote
  #2  
Old 05-18-2017, 05:42 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
 
Join Date: Apr 2010
Location: Clayton MI
Posts: 42,651
Default

P0783 3-4 Shift Sol, No RPM Drop at Lockup

That's not really a surprise....... at least the symptoms match the code.

Did you change to O/D solenoid as well?
Reply With Quote
  #3  
Old 05-18-2017, 05:47 PM
Jason.tiger
Jason.tiger is offline
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 9
Default

Quote:
Originally Posted by HeyYou View Post
P0783 3-4 Shift Sol, No RPM Drop at Lockup

That's not really a surprise....... at least the symptoms match the code.

Did you change to O/D solenoid as well?

no i did not.
Reply With Quote
  #4  
Old 05-18-2017, 05:49 PM
Jason.tiger
Jason.tiger is offline
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 9
Default

And I just turned it (OD)on and off earlier today and there was no change whatsoever. Hopefully that's the culprit.
Reply With Quote
  #5  
Old 05-18-2017, 06:03 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
 
Join Date: Apr 2010
Location: Clayton MI
Posts: 42,651
Default

Did the lite on the switch change state when you pressed it?
Reply With Quote
  #6  
Old 05-18-2017, 06:04 PM
Jason.tiger
Jason.tiger is offline
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 9
Default

Quote:
Originally Posted by HeyYou View Post
Did the lite on the switch change state when you pressed it?
light went off when turned off and on when on. And I just looked and it turns out I did change the OD solenoid!
Reply With Quote
  #7  
Old 05-18-2017, 07:29 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
 
Join Date: Apr 2010
Location: Clayton MI
Posts: 42,651
Default

Well, if the trans shifts, and you get TCC lockup, then the trans is actually getting power. Verify you are getting power thru the O/D solenoid, connector B on the PCM, pin 21. Should be a brown wire. Have to test with the connector plugged in.... so, just bare a bit of wire, so you can get a probe on it. Should see 12 volts there.
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 11:31 AM.