dodge 2003 ram - DodgeForum.com

Notices
3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

dodge 2003 ram

Reply

 
 
 
  #1  
Old 02-02-2012, 11:21 PM
art4u24
art4u24 is offline
Registered User
Thread Starter
Join Date: Feb 2012
Posts: 3
Default dodge 2003 ram

I have a dodge ram 1500 2003 5.7 I am having problems with my trailer brake lights. Everything on the right side of my trailer works but the left side of the trailer I don't have a brake light.

The left turn signal works, the flashers work. I even hooked up another truck and the trailer works just fine. What else could it be?
 
Reply With Quote
  #2  
Old 02-05-2012, 04:02 PM
lxman1's Avatar
lxman1
lxman1 is offline
Site Moderator
Dodge Forum Moderator
Join Date: May 2008
Location: Louisville, Ky
Posts: 9,456
Default

Welcome to the forum Have you checked all of the fuses in the box under the hood?
 
Reply With Quote
  #3  
Old 02-05-2012, 09:31 PM
weedahoe's Avatar
weedahoe
weedahoe is offline
Hall Of Fame
Hall of Fame Member
Join Date: Mar 2009
Location: South GA
Posts: 19,155
Default

Yeah, fuses is where I would start also.
 
Reply With Quote
  #4  
Old 02-05-2012, 10:20 PM
vegastom69
vegastom69 is offline
Registered User
Join Date: Sep 2010
Posts: 22
Default

check the bulb on the trailer ?????????????? also check the wires on the trailer broken also ckeck the trailer plug
 
Reply With Quote
  #5  
Old 02-06-2012, 02:18 PM
extremis
extremis is offline
Professional
Join Date: Aug 2006
Location: Mission, BC
Posts: 116
Default

The output on our trucks is relayed. There is probably a lighting relay under the hood as well. Check those. Also, the other truck you tested with may not be relayed, and the ground feeds back through the circuit. I ran into this when I bought a little utility trailer. Owners Ranger lit things up fine, my truck would not. the cause, no proper ground on the trailer lights. I added it from the 4 pin harness to the lights and bang it works right. So, check that the ground is good on the trailer from the light to the plug (some grounds are via chassis)
 
Reply With Quote
  #6  
Old 02-07-2012, 03:31 PM
art4u24
art4u24 is offline
Registered User
Thread Starter
Join Date: Feb 2012
Posts: 3
Default

Yes, I looked at all of they that go to any and all lights, they are all good. Nothing wrong with the trailer because I hooked up another truck to it and trailer lights all work like they should. I guess it's got to be with my wiring on the truck.
 
Reply With Quote
  #7  
Old 02-07-2012, 03:37 PM
art4u24
art4u24 is offline
Registered User
Thread Starter
Join Date: Feb 2012
Posts: 3
Default

Well, guys thanks for all of your help but I still have the same problem. Everything on the trailer has been checked and double checked there isn't any problem with it.

It has to be the wiring some where, Dodge wants $90.00 to scan it but I am thinking to take it to someone in town who can just replace the whole wiring with a new one. Other than that truck runs get and I just love it. Best part it's paid off......
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Quick Reply: dodge 2003 ram


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: