Bad governor solenoid? - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Reload this Page > Bad governor solenoid?
Notices
3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Bad governor solenoid?

Reply

 
 
  #1  
Old 07-16-2017, 04:01 PM
TheTietzify
TheTietzify is offline
New Member
Thread Starter
Join Date: Jul 2012
Posts: 4
Default Bad governor solenoid?

I recently started getting issues with my transmission. It's having a tough time going from 1st to 2nd. when i am accelerating fairly slow it has no problem going into 2nd gear. It only stutters going into 2nd when accelerating a bit faster. I adjusted both bands and replaced the governor solenoid and that other plastic sensor. Is there only one way the plug goes into the governor solenoid? Is there anything else i can check?
 
Reply With Quote
  #2  
Old 07-16-2017, 04:02 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 43,399
Default

What year is your truck?
 
Reply With Quote
  #3  
Old 07-16-2017, 07:27 PM
TheTietzify
TheTietzify is offline
New Member
Thread Starter
Join Date: Jul 2012
Posts: 4
Default

2006 Ram 3500
 
Reply With Quote
  #4  
Old 07-17-2017, 09:25 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 43,399
Default

Moving this to the third gen ram section for ya.
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 12:46 PM.