318 Poly Help - Page 2 - DodgeForum.com


Notices

Charger, Roadrunner & Superbee Talk Charger (pre-1975). Coronet, Roadrunner and Superbee (& other 'B' bodies) specific topics within.

View Poll Results: A poll
I have a Poly, and run it!
50.00%
I'm building one!
10.00%
Had one, dumped it.
10.00%
I want one!
10.00%
Poly Whaaaaat???????
20.00%
Voters: 10. You may not vote on this poll

318 Poly Help

Reply
 
 
  #11  
Old 12-10-2007, 10:16 AM
Abomination
Abomination is offline
Thread Starter
 
Join Date: Jan 2007
Location: Kansas City, MO
Posts: 22
Default RE: 318 Poly Help

No problem, man.

Craig Fountain makes finned aluminum valve covers for 'em, but he's in Australia, and although you can get 'em through a few distributors (like Gary on the 318 Poly Yahoo group) they're still about $400 or so. Hall, Edelbrock made a 3x2 and a set of finned aluminum valve covers for 'em back in the day, and the intake is $400 - $500 nowadays, and those original finned aluminum valve covers have gone for as much as $800!!!

Most guys just have 'em chromed or do the crinkle coat - it's cheaper by far, and you can put that money into some go-fast parts.

Seriously, check out those two boards I mentioned - especially the Yahoo one (which has pics, speed secrets, tricks, etc).

~Jason
Reply With Quote
  #12  
Old 12-12-2007, 06:16 AM
Ray Bell
Ray Bell is offline
Registered User
 
Join Date: Oct 2005
Posts: 5
Default RE: 318 Poly Help

How about this for a neat Poly setup... and not expensive!

http://img339.imageshack.us/img339/3...318polyia2.jpg

Belongs to a South Australian Phoenix (you'd think it was a Plymouth!) owner...
Reply With Quote
  #13  
Old 12-06-2008, 12:55 PM
tattd56
tattd56 is offline
Registered User
 
Join Date: Nov 2008
Posts: 3
Default 318 poly help

I have a 318 poly in a 56 dodge truck. I am not sure whaat year the engine is. The guy i bought it said it is origional, which i highly doubt as they came with flat head 6 cyl. Anyway, i have seen websites that tell how to identify by looking on the front of the block on the drivers side, bu ti do not see any markings here. Also the oil filter is located on the firewall in a drop in canister, which is also not in any poly pics i have seen. Could this just be a re plumb job? I cant get an oil filter with out knowing the year and other info on the engine. Please help. Thanks guys!
Reply With Quote
  #14  
Old 06-22-2009, 03:39 AM
SPARTANENGINEER1701's Avatar
SPARTANENGINEER1701
SPARTANENGINEER1701 is offline
Professional
 
Join Date: May 2009
Posts: 106
Default 318 poly

1 it shhould be a carter wcfb

they sell stroker kits to 408cid

heads need some port work

the exhaust headers all the way eletronic ignition

make sure the flange on the crank is proper for your application

it a slant six on roids

tapping valves but it runns for ever.

feel free to correct me

up grade oilpump no matter what
Reply With Quote
  #15  
Old 07-08-2009, 09:50 AM
tattd56
tattd56 is offline
Registered User
 
Join Date: Nov 2008
Posts: 3
Default

Thanks for the info , big help, ill look inot all that.
I do have another question, my water pump went on this badboy andi am trying to locate a replacement one. Anyone have any ideas on where to find one? Thanks again
Reply With Quote
  #16  
Old 10-30-2009, 06:54 PM
Ray Bell
Ray Bell is offline
Registered User
 
Join Date: Oct 2005
Posts: 5
Default Did anyone keep it?

Particularly aimed at Jason... Abomination...

Did anyone keep the data from the Geocities Poly site?

Looking for some of the pics. Do they still exist anywhere?
Reply With Quote
  #17  
Old 05-30-2015, 04:23 PM
chargeral
chargeral is offline
Registered User
 
Join Date: May 2015
Posts: 1
Default Trouble with wifes 318 Poly.

My wifes 66 Charger is giving me trouble. 318 rebuilt with less than 3000 miles on the engine. Last year ran rough and ate gas (8 mpg). Replaced distributor and had the Stromberg 2barrel rebuilt (twice). Still ran bad. Had a second Stromberg, had that rebuilt and the engine ran fine. Took the Charger for a 60 mile trip and no problem. The other day went to run the car and it started back firing and stalling. Not sure what to check now. Any one have any ideas?
Reply With Quote
  #18  
Old 05-31-2015, 09:16 AM
Moparite's Avatar
Moparite
Moparite is offline
Record Breaker
 
Join Date: Feb 2015
Posts: 1,987
Default

Well i'm not to familiar with the polys but where the valve seats replace for hardened ones when it was rebuilt? Leaded gas lubricated the valves back then. Running non hardened seats with the gas today the valves will bury themselves in the head in a short time. I'm guessing you still have the points set up? Did you check them?
Reply With Quote
  #19  
Old 05-31-2015, 10:14 AM
Daves69
Daves69 is offline
Veteran
 
Join Date: Dec 2012
Location: Chi - west
Posts: 285
Default

Quote:
Originally Posted by chargeral View Post
My wifes 66 Charger is giving me trouble. 318 rebuilt with less than 3000 miles on the engine. Last year ran rough and ate gas (8 mpg). Replaced distributor and had the Stromberg 2barrel rebuilt (twice). Still ran bad. Had a second Stromberg, had that rebuilt and the engine ran fine. Took the Charger for a 60 mile trip and no problem. The other day went to run the car and it started back firing and stalling. Not sure what to check now. Any one have any ideas?

Actually you should start a new thread as it's off the OPs topic.
check all ignition
check compression
put a vacuum gauge on it
Reply With Quote
  #20  
Old 05-31-2015, 05:52 PM
Moparite's Avatar
Moparite
Moparite is offline
Record Breaker
 
Join Date: Feb 2015
Posts: 1,987
Default

That plus it's six years old.
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ballen28677
Archived Classifieds
0
07-14-2007 11:35 AM
ballen28677
Archived Classifieds
0
07-14-2007 11:33 AM
Abomination
Dodge Classics
0
03-21-2007 12:26 PM
Abomination
Other Vintage Dodges
0
03-21-2007 12:25 PM
kcarwagon
1st Gen Ram Tech
1
04-22-2005 03:21 AM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 01:14 AM.