2.5 hanging throttle and rough idle - DodgeForum.com


Notices

Dodge Daytona The G platform cars that are to this day, fun sporty machines that car modding enthusiasts love to get their hands on, the Dodge Daytona and Chrysler Laser.

2.5 hanging throttle and rough idle

Reply
 
 
  #1  
Old 10-29-2014, 09:54 PM
greenweenie
greenweenie is offline
Professional
Thread Starter
 
Join Date: May 2007
Location: Seattle
Posts: 113
Default 2.5 hanging throttle and rough idle

I've got a couple of problems that may be related, I've thrown a lot of time and nickels at this thing to no end. 94 Dakota, 2.5, 5 speed manual. I know this is the Daytona forum but there are many more Daytonas with 2.5's than Dakotas so I figured I'd have better luck here.

The two symptoms are:

Engine does not come back down to normal idle speed quickly, it hangs for a 3-4 seconds after releasing the throttle. It started doing this randomly several weeks ago.

I have a rough idle, I can hear "puffs" from the exhaust pipe at idle which seams to indicate it's a misfire. It idles smoothly after cold starts, and seems to get progressively worse as the engine warms up.

Otherwise the engine seems to run fine.

What I have done:
New injector, rebuilt throttle body, new IAC
New wires, plugs, distributor, ignition coil
Check ignition timing, 12* per FSM
New crank position sensor
New coolant temperature sensor
Checked all vacuum lines, new air filter
Checked for ODB trouble codes, none
New head gasket
New intake gasket
New o2 sensor
Unplugged the computer for 30 minutes in attempt to reset it

All to no avail. What do you guys think?

Thanks
Reply With Quote
  #2  
Old 10-30-2014, 12:45 PM
smokesxt's Avatar
smokesxt
smokesxt is offline
All Star
 
Join Date: Aug 2009
Location: poynette WI
Posts: 944
Default

Check your Coolant temp sensor.
Backprobe it from a cold start.



Start with that as everything else is controlled by input from the Coolant sensor.
I'd also check the IAC if its not the CTS, I've never gotten a new one that lasted more then a couple weeks, so I went back to one I got from a JY, Issues solved.
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jesse1562
1st Gen Dakota
3
10-26-2015 03:52 PM
Miketech137
Dodge Caravan
5
10-20-2015 06:27 PM
zramsst
2nd Gen Ram Tech
3
08-11-2015 01:00 AM
MoparNut87
1st Gen Durango
9
07-30-2015 04:30 PM
JoshuaYsassi
2nd Gen Ram Tech
63
07-24-2015 12:14 AM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 12:25 AM.