2005 Dodge Magnum Transmission Problems - DodgeForum.com

Go Back  DodgeForum.com > Dodge Cars > Dodge Magnum
Reload this Page >

2005 Dodge Magnum Transmission Problems

Dodge Magnum The Dodge Magnum, the wagon that made wagons cool. The unique look of the Dodge Magnum makes any trim level, from SE to SRT-8, an absolute head turner.

2005 Dodge Magnum Transmission Problems

Reply

 
 
 
  #1  
Old 07-16-2018, 12:17 AM
05DodgeMagnum
05DodgeMagnum is offline
Registered User
Thread Starter
Join Date: Jul 2018
Posts: 7
Default 2005 Dodge Magnum Transmission Problems

What's up guys I have a 2005 dodge magnum with a 2.7 l motor. I recently had a shop redo the rear main seal which I regret they did something g to the transmission. Its stuck in 2nd gear in limp mode. I dropped the pan and the fluid looked like water so I replaced the filter and put brand new fluid in but still didn't do the trick. Is there anything else I can check before dropping the valve body? I got p0750 on my scanner. The transmission was working fine before they did this. Any help would be awesome I love my magnum thanks.
 
Reply With Quote
  #2  
Old 07-16-2018, 08:49 AM
jkeaton's Avatar
jkeaton
jkeaton is offline
DF Admin
Dodge Forum Administrator
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 24,220
Default

The obvious response is take it up with the shop that messed it up.....why would you not do that?
 
Reply With Quote
  #3  
Old 07-16-2018, 09:18 AM
05DodgeMagnum
05DodgeMagnum is offline
Registered User
Thread Starter
Join Date: Jul 2018
Posts: 7
Default

Because it sat there for 6 months and they could not figure it out so I recently towed it home so I could try to find the problem.
 
Reply With Quote
  #4  
Old 07-16-2018, 11:09 AM
jkeaton's Avatar
jkeaton
jkeaton is offline
DF Admin
Dodge Forum Administrator
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 24,220
Default

Aw man.... that sucks. The fluid looked like water, meaning it was clear?
 
Reply With Quote
  #5  
Old 07-16-2018, 11:45 AM
05DodgeMagnum
05DodgeMagnum is offline
Registered User
Thread Starter
Join Date: Jul 2018
Posts: 7
Default

Originally Posted by jkeaton View Post
Aw man.... that sucks. The fluid looked like water, meaning it was clear?
it looked like water it was red but real thin. I dont know how to resize
 
Reply With Quote
  #6  
Old 07-17-2018, 11:02 AM
05DodgeMagnum
05DodgeMagnum is offline
Registered User
Thread Starter
Join Date: Jul 2018
Posts: 7
Default

Is there any way to check the ohms on the speed sensors? Or what can I check before replaci.g the solenoid pack?
 
Reply With Quote
  #7  
Old 07-17-2018, 01:54 PM
TNtech's Avatar
TNtech
TNtech is offline
Site Moderator-Dodge Tech
Dodge Forum Moderator
Join Date: Sep 2010
Location: Nashville, Tennessee
Posts: 3,679
Default

Take another picture please.
 
Reply With Quote
  #8  
Old 07-17-2018, 03:11 PM
05DodgeMagnum
05DodgeMagnum is offline
Registered User
Thread Starter
Join Date: Jul 2018
Posts: 7
Default

 
Reply With Quote
  #9  
Old 07-17-2018, 03:12 PM
05DodgeMagnum
05DodgeMagnum is offline
Registered User
Thread Starter
Join Date: Jul 2018
Posts: 7
Default

That was when I first dropped the pan. I've replaced the filter and fluid.
 
Reply With Quote
  #10  
Old 07-17-2018, 07:56 PM
05DodgeMagnum
05DodgeMagnum is offline
Registered User
Thread Starter
Join Date: Jul 2018
Posts: 7
Default

Anybody know the connector name this was located on top of the transmission the top right one was tore they tried to sauder it but it came off. I'm hoping this is causing the problem. They tore 1 wire but had enough to fix it.
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Quick Reply: 2005 Dodge Magnum Transmission Problems


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: