1998 neon only starts with starter fluid - DodgeForum.com


Dodge Neon The sport compact car that took the world by storm. the Dodge Neon. Depending on the trim level you get, this sporty ride has something to offer everyone.

1998 neon only starts with starter fluid

Reply
 
 
  #1  
Old 08-04-2012, 11:46 AM
mroban
mroban is offline
Registered User
Thread Starter
 
Join Date: Aug 2012
Posts: 3
Default 1998 neon only starts with starter fluid

I have a 1998 neon I replaced the fuel pump and filter. It ran for a couple of days then quit starting. I am able to start it with starting fluid. it runs and drives find but will not start up when you shut it off. I have low pressure at the fuel rail. I do hear the pump prime. checked fuses and pump relay. could it be the cam sensor? Another bad pump? Could the filter get plugged that quickly? any Idea where I should go from here? Thanks for your help.
Reply With Quote
  #2  
Old 08-06-2012, 01:47 PM
I_Ride_Neon's Avatar
I_Ride_Neon
I_Ride_Neon is offline
Record Breaker
 
Join Date: Nov 2007
Location: Dubuque, Iowa
Posts: 2,004
Default

How much fuel pressure? Does it drop or will it hold it in the rail for a while? Cam sensor will cause the fuel pump to not kick on. It will also throw a CEL code. Check CEL codes first. Was the problem there before you changed the fuel pump? Who changed it? Did you change the whole sennding unit with a new regulator on it? What filter did you change? I was unaware of a fuel filter on a neon. Just the accumulator and fuel pump sock. If you changed the accumulator make sure the lines are not backwards.
Reply With Quote
  #3  
Old 08-06-2012, 02:07 PM
mroban
mroban is offline
Registered User
Thread Starter
 
Join Date: Aug 2012
Posts: 3
Default

After the fuel pump primes there is no pressure in the fuel rail. We changed the fuel filter right outside the tank coming from the fuel pump. I will check the CEL codes and get back to you. Thanks.
Reply With Quote
  #4  
Old 08-06-2012, 06:26 PM
I_Ride_Neon's Avatar
I_Ride_Neon
I_Ride_Neon is offline
Record Breaker
 
Join Date: Nov 2007
Location: Dubuque, Iowa
Posts: 2,004
Default

If you start the car with starter fluid does the pump kick on and take over? I would inject power to the pump and see if it works properly.
Reply With Quote
  #5  
Old 08-07-2012, 05:38 PM
mroban
mroban is offline
Registered User
Thread Starter
 
Join Date: Aug 2012
Posts: 3
Default

I checked the CEL codes and came up with 12,21,55. nothing for the cam position sensor. How do you inject power to the pump?
Reply With Quote
  #6  
Old 08-07-2012, 05:55 PM
I_Ride_Neon's Avatar
I_Ride_Neon
I_Ride_Neon is offline
Record Breaker
 
Join Date: Nov 2007
Location: Dubuque, Iowa
Posts: 2,004
Default

Should be able to inject power at the fuse prongs. First have some one prime the pump and see which prong goes to the pump, and which one is the power. Once you determined the prong going to the pump inject power and start the car. Also the codes are not related to the fuel pump. 21 is for an o2 sensor, but this could be caused by the fuel issue your already having. Do you have an injector pigtail tester, or can you get one? It has a light on it and blinks with the injector pulse. You can also use a your basic light up power tester. Make sure you are getting injector pulse.
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pamela24
Dodge Caravan
6
10-21-2015 05:33 AM
janicedauw
Dodge Caravan
1
08-08-2015 02:12 AM
grizzly_adams
3rd Gen Ram Tech
8
07-11-2015 09:59 AM
colons3499
Dodge Neon
0
07-09-2015 03:57 PM
Dalbert
Dodge Ram Van
8
07-08-2015 10:33 AM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 09:05 AM.