05 Neon 2.0 no crank no start no click - DodgeForum.com

Go Back  DodgeForum.com > Dodge Cars > Dodge Neon
Reload this Page >

05 Neon 2.0 no crank no start no click

Dodge Neon The sport compact car that took the world by storm. the Dodge Neon. Depending on the trim level you get, this sporty ride has something to offer everyone.

05 Neon 2.0 no crank no start no click

  #1  
Old 11-26-2018, 08:21 AM
Dave Rogers
Dave Rogers is offline
Registered User
Thread Starter
Join Date: Nov 2018
Posts: 2
Default 05 Neon 2.0 no crank no start no click

Hi ,
I have a 05 Neon 2.0/automatic with 150k miles.

Currently it is no crank no start no click.

All the dash lights come on. radio, etc. NO CHECK ENGINE LIGHT self test on key turn

I had what I assume a loose ground wire on the battery. ( I would whack the ground battery post with a wrench and it would start for a few days, but now nothing.)
It was also cranking when this battery terminal thing happened, but i assume it wasn't getting enough juice.
Cleaned up the terminal, no go..
replaced the battery, no go.

cleaned up engine/body grounds, no go.

When turning the key, no dimming of the lights etc, ( radio shuts off like when starting the car)

I jumped the starter relay with a paper clip ( 30 and 86 pin) and the starter cranks like a boss.
Also, swapped the starter relay with the known good horn relay and still nothing.

Since jumping the relay turns it over, i assume everything beyond my starter , ground, etc is good.

continuity test on all grounds and power to starter ( 12v) are good.

tested all small fuses inside and out and there good.

Am i correct in assuming if i get dash lights, etc, ignition pin is good?

I feel like i have it nailed down to the Neutral sensor or the ECM.

Shifting to N vs P doesn't make a difference.

Is there actually a neutral sensor to replace or does it all get handled by the ECM?

Trying to avoid getting a new ECM for troubleshooting purposes if Im missing a ground or something stupid..

Aside from the NO CHECK ENGINE LIGHT SELF test, it acts like it is not in Park.

gave all the cables/sensors the "thump test"

Any ideas/advice internet? Any help would be greatly appreciated.

Thanks,
Dave


 
  #2  
Old 11-27-2018, 06:35 AM
Dave Rogers
Dave Rogers is offline
Registered User
Thread Starter
Join Date: Nov 2018
Posts: 2
Default

--Edit: sorry, the CHECK ENGINE LIGHT DOES COME ON after about 15 sec of leaving the key alone and turned.

The red circle ( Security/AntiTheft light) is also on solid and constant. From what Ive read of this, could be caused by bad wiring to ECM or no comm to ECM or a faulty security code. ( I dont have a code reader or a security system.)

going to try disconnecting the brand new battery again and doing a full discharge of the power after work today.

I tried finding a 5v reference in what i believe to be the throttle sensor but couldn't . going to try again today now that i know a bit more about it. If ECM is bad, ( or if a sensor is shorted) , there will be less than 5v on the sensor to ground.

Apparently the 05 Neon doesnt have a neutral safety switch, but rather it is handled by the Transmisson Control Module ( TCM). It is buried in the tranny worse than your weird uncle Victor. so im hoping to avoid that.

I'm assuming the ignition pin is good since the key bounces back. Am I wrong in assuming this? Thinking out loud at this point. Oh where art thou, Internet Dodge Neon gurus?
 

Thread Tools
Search this Thread
Quick Reply: 05 Neon 2.0 no crank no start no click


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: