Turn Signals, Hazards, Brake Lights not working - DodgeForum.com

Go Back  DodgeForum.com > Dodge SUVs > Ramcharger, Trailduster & Power Wagon
Reload this Page >

Turn Signals, Hazards, Brake Lights not working

Ramcharger, Trailduster & Power Wagon Grrrr!! Tough Trucks! The Dodge Ramcharger and Plymouth Trailduster were full size SUV's that had good looks and brute strength. The Dodge Power Wagon was comparable to them in toughness, but came in pickup truck form only.

Turn Signals, Hazards, Brake Lights not working

  #1  
Old 04-26-2009, 11:28 PM
tigerhornet
tigerhornet is offline
Registered User
Thread Starter
Join Date: Jul 2008
Posts: 27
Default Turn Signals, Hazards, Brake Lights not working

My headlights work fine, but the turn signals, hazard lights, and brake lights don't work. when i hit either the hazard light switch or the turn signal switch, absolutely nothing happens, no click, no indicator lights.
 
  #2  
Old 04-26-2009, 11:46 PM
BlueBeast2's Avatar
BlueBeast2
BlueBeast2 is offline
Champion
Join Date: Jul 2005
Location: Parkesburg, PA
Posts: 2,953
Default

My guess would be the multi-function switch
 
  #3  
Old 04-26-2009, 11:48 PM
xray99
xray99 is offline
Banned
Join Date: Apr 2009
Location: MI USA
Posts: 967
Default

Sounds like you got a wiring gremlin, try changing the flasher fuses yet ?
 
  #4  
Old 07-28-2010, 11:45 AM
n_greenscapes
n_greenscapes is offline
Registered User
Join Date: Jul 2010
Posts: 1
Default

tigerhornet, did you ever figure out what was wrong with your truck? I have a '97 2500 and the same thing is happening to me. I replaced the multi-function switch and stop lamp switch and nothing happened.
 
  #5  
Old 07-28-2010, 11:55 AM
Maxx_Magnum's Avatar
Maxx_Magnum
Maxx_Magnum is offline
Record Breaker
Join Date: Jan 2009
Location: NB, Canada
Posts: 2,222
Default

parklight fuse?
 
  #6  
Old 07-28-2010, 04:28 PM
2k10HemiRam
2k10HemiRam is offline
Captain
Join Date: Jun 2007
Location: Las Vegas, NV
Posts: 520
Default

I still have a fun issue with my right blinkers, everything works just flashes super fast which sounds annoying, but try replacing the flasher/hazard light replay. The relays changed over the generation but I thing pre-99 the flasher/hazard light relays were two separate round silver relays in the cab relay box. Think it was 99 then combined the two into a single blue square relay. It's only 32 bucks at autozone, gonna pick me one up this weekend after i get paid and see if that fixes that problem.
 
  #7  
Old 10-21-2010, 09:48 PM
dazza5757
dazza5757 is offline
Registered User
Join Date: Oct 2010
Posts: 3
Default

Hi I know what your problem is, had the exact same problem, fix is easy your problem is the connection where the light bulb plugs into holder. Take bulbs out and clean plug contacts with a fine flat file, then make sure bulbs are pushed back correctly.
And you problem should be solved. I did this to all 4 front indicator bulbs and been fine since. Darren
 
  #8  
Old 05-12-2011, 12:58 PM
hombre
hombre is offline
Registered User
Join Date: May 2011
Posts: 1
Default

I have same problem. Cleaned contacts no success
 
  #9  
Old 05-12-2011, 01:03 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 55,574
Default

do ANY of the rear lights work?
 
  #10  
Old 12-10-2011, 09:38 AM
SoGone12
SoGone12 is offline
Registered User
Join Date: Dec 2011
Posts: 2
Default Any luck guys!?

Is there any update on this problem? I'm having the SAME problem on my 98 Dakota V6. My head lights and tail lights work but NO reverse lights, turns signals on either side/either end, and NO brake lights. I've tried checking fuses, changing the brake light switch under the brake petal, changing the multifunction switch on the steering column and checking the bulbs. I GUESS i'll go through it and check the connections today but it was just weird how they went out one by one. First no Turn signals in front, then in back, then no brake lights (only the third light at the top of the cab), then THAT went out. Seeing as how there's no sound or response when i hit the multifunction switch I'll assume no power is getting there. Thats my target.
 

Thread Tools
Search this Thread
Quick Reply: Turn Signals, Hazards, Brake Lights not working


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: