Go Back   DodgeForum.com > Dodge SUVs > Dodge Durango > 1st Gen Durango
Sign in using an external account
Register Forgot Password?


1st Gen Durango 1998 - 2003 Durango's

so I got this durango.... with some issues...

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-19-2013, 09:12 PM
JasonJacquard JasonJacquard is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2013
Posts: 7
Default so I got this durango.... with some issues...

Hey not new to working on cars, however I picked up a 2000 durango, and it had work done to it, but the guy gave up either he was truthful and doesn't know the issue and his work (will describe below) was done correctly, or he knows he messed it up and sold it. SO now I have it, and here is the my issues, I will also go and post in the correct forum as well.

4.7l engine, guy said he did the timing chain, and replaced a couple of valves and put it all back together and it just wont run under 1500 rpm.

Now I picked it up as it seems to run with out a hitch at said rpm, and if you remove the little caps on the intake manifold it will idle but high, though as soon as you press the gas it sputters and hates life if you feather the gas when its sputtering and get it up to 1500 it will go back down to idle. As soon as you put a cap on it, it dies.

I have cleaned the TB, and went to the yards and got 3 tps/and iac valves and I've had no change in the performance of it.

It does however have 215K on the clock and if I could find a 4.7l for a few hundred I'd just swap it out, but I can't even find one to have that option.

I've also bought a new iac just in the event all 4 of mine were bad, and no change. I'm at a loss as well with the guy I got it from. Though I'm no durango guy, but I'm a cherokee so I know all too well of electrical gremlins.


Lastly codes I get say misfires and such, I can change out whatever coil it is, and that one will go away, but then it moves or something really random and doubt its the issue, when I get it at idle and unplug a coil at a time I notice a change, so I know they are all working. Other than that I get no codes. I did get it with out any ground wires on the passenger side, and I went to the wrecking yard today and picked up said ground wire and attached it and still has the issues.

any help would be great!!!
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 08-19-2013, 09:34 PM
that_guy's Avatar
that_guy that_guy is online now
Champion
Garage is empty, add now
 
Join Date: Jan 2011
Vehicle: 99 Durango SLT FT4X4 5.2L Intense Blue
Location: Pittsburgh, PA or Columbia, SC
Posts: 2,838
Default

A weak battery or poor battery connections can cause it to not want to idle, and all sorts of other weird issues. That'd be an easy thing to check before driving yourself crazy with all sorts of other things.
__________________

-Intense Blue '99 Durango SLT 5.2L FT4X4
-Ivy Green '69 Plymouth Satellite 318
Quote:
Somewhere in Kenya, a village is missing its idiot.
Reply With Quote
  #3  
Old 08-19-2013, 09:42 PM
JasonJacquard JasonJacquard is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2013
Posts: 7
Default

I will check that now, I just wish the 4.7 engine was a plentiful as the larger v-8s!
Reply With Quote
  #4  
Old 08-19-2013, 09:47 PM
that_guy's Avatar
that_guy that_guy is online now
Champion
Garage is empty, add now
 
Join Date: Jan 2011
Vehicle: 99 Durango SLT FT4X4 5.2L Intense Blue
Location: Pittsburgh, PA or Columbia, SC
Posts: 2,838
Default

That's just because the 5.2L and 5.9L have been around for decades compared to the 4.7L which has only been around since 99.
__________________

-Intense Blue '99 Durango SLT 5.2L FT4X4
-Ivy Green '69 Plymouth Satellite 318
Quote:
Somewhere in Kenya, a village is missing its idiot.
Reply With Quote
  #5  
Old 08-19-2013, 09:52 PM
JasonJacquard JasonJacquard is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2013
Posts: 7
Default

well right now I'm making up a co sensor. The y-pipe cut, and he cut off the co that came on the car, and I had a co sensor laying around, 4-wire so I'm going to splice a connection and check the terminals/clean them up and go for another round, I will say though that the exhaust being cut there, this v-8 sounds pretty mean!!
Reply With Quote
  #6  
Old 08-19-2013, 10:15 PM
JasonJacquard JasonJacquard is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2013
Posts: 7
Default

no change
Reply With Quote
  #7  
Old 08-19-2013, 10:23 PM
JasonJacquard JasonJacquard is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2013
Posts: 7
Default

starting to think that the timing is off... this should be fun to check...
Reply With Quote
  #8  
Old 08-20-2013, 01:39 AM
PublicHair PublicHair is offline
Banned
Garage is empty, add now
 
Join Date: Jul 2013
Posts: 696
Default

Interesting
Reply With Quote
  #9  
Old 08-20-2013, 10:23 AM
that_guy's Avatar
that_guy that_guy is online now
Champion
Garage is empty, add now
 
Join Date: Jan 2011
Vehicle: 99 Durango SLT FT4X4 5.2L Intense Blue
Location: Pittsburgh, PA or Columbia, SC
Posts: 2,838
Default

I suppose it's possible the previous owner could have screwed up the timing. Just make sure all the marks line up.
__________________

-Intense Blue '99 Durango SLT 5.2L FT4X4
-Ivy Green '69 Plymouth Satellite 318
Quote:
Somewhere in Kenya, a village is missing its idiot.
Reply With Quote
  #10  
Old 08-20-2013, 05:21 PM
JasonJacquard JasonJacquard is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2013
Posts: 7
Default

well I went the yard today and picked up a y-pipe and a 02 sensor as it currently doesn't have one, well it has a y-pipe but they PO cut out the cat, and when he did that he went threw the 02 sensor and bung so I needed a new to me one anyhow, not too bad at the yard, it was 5 bucks, now to lift up the durango and drop a drive line and install, and see if that helps at all...
Reply With Quote
Old 08-20-2013, 05:21 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 05:28 PM.

Internet Brands, Inc.


Contact Details & Emails