Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech > 2nd Gen RAM general discussion/NON-tech
Sign in using an external account
Register Forgot Password?


2nd Gen RAM general discussion/NON-tech This section is for general discussions about your 2nd gen RAM. Non tech related RAM threads belong here.

What Am I Doing Wrong?

Closed Thread
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-30-2013, 04:55 PM
UnregisteredUser's Avatar
UnregisteredUser UnregisteredUser is offline
Champion
1998 Dodge Ram 1500
 
Join Date: Apr 2010
Vehicle: 1998 Dodge Ram 1500 5.9l 4x4
Location: Meeker, CO
Posts: 3,849
Default What Am I Doing Wrong?

I don't know what I'm doing wrong here. My truck runs great, gets good fuel economy for what it is, the steering doesn't wander, the heater works great, the transmission is hell for strong, and even the factory original headlights are not hazed. The stupid plenum gasket is still intact, too. And the dash isn't cracked.

I don't get it. What am I doing wrong?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
__________________

A bad attitude and a Mega Viper.
Dash isn't cracked, steering doesn't wander, headlights are awesome, has good heat.

Last edited by UnregisteredUser; 07-30-2013 at 05:07 PM..
  #2  
Old 07-30-2013, 05:11 PM
zman17's Avatar
zman17 zman17 is offline
Section Moderator
Dodge Forum Moderator
2000 Dodge Ram 2500
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,725
Default

You regularly do maintenance ? And don't include that Mega Viper in your statement! Good to see you back btw.
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP
  #3  
Old 07-30-2013, 05:31 PM
dodge dude94 dodge dude94 is offline
Banned
1998 Dodge Ram 1500
 
Join Date: Jun 2010
Vehicle: 1998 Ram 1500 QCSB 360 4x4
Location: East Texas
Posts: 8,923
Default

HOLY SH1T!!!!!


YOU'RE BACK!!


I missed you man. You actually staying?
  #4  
Old 07-30-2013, 05:40 PM
UnregisteredUser's Avatar
UnregisteredUser UnregisteredUser is offline
Champion
1998 Dodge Ram 1500
 
Join Date: Apr 2010
Vehicle: 1998 Dodge Ram 1500 5.9l 4x4
Location: Meeker, CO
Posts: 3,849
Default

Quote:
Originally Posted by zman17 View Post
You regularly do maintenance ?
Is that the problem? Maybe I ought to knock that off so I have an excuse to come around the forum more often.

Oh yeah! My instrument cluster bezel is in great shape, too.

Quote:
Originally Posted by zman17 View Post
Good to see you back btw.
I figured I oughta pop in and say hi as long as I'm just sitting around with nothing but stalled projects. I hope all's well in your world.
__________________

A bad attitude and a Mega Viper.
Dash isn't cracked, steering doesn't wander, headlights are awesome, has good heat.
  #5  
Old 07-30-2013, 05:44 PM
UnregisteredUser's Avatar
UnregisteredUser UnregisteredUser is offline
Champion
1998 Dodge Ram 1500
 
Join Date: Apr 2010
Vehicle: 1998 Dodge Ram 1500 5.9l 4x4
Location: Meeker, CO
Posts: 3,849
Default

Quote:
Originally Posted by dodge dude94 View Post
HOLY SH1T!!!!!
You've misspelled wholly, man.

Quote:
Originally Posted by dodge dude94 View Post
You actually staying?
I'll probably try to get around these parts more often, but there's just no telling what I might do.
__________________

A bad attitude and a Mega Viper.
Dash isn't cracked, steering doesn't wander, headlights are awesome, has good heat.
  #6  
Old 07-30-2013, 07:00 PM
zman17's Avatar
zman17 zman17 is offline
Section Moderator
Dodge Forum Moderator
2000 Dodge Ram 2500
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,725
Default

Quote:
Originally Posted by UnregisteredUser View Post
Is that the problem? Maybe I ought to knock that off so I have an excuse to come around the forum more often.

Oh yeah! My instrument cluster bezel is in great shape, too.



I figured I oughta pop in and say hi as long as I'm just sitting around with nothing but stalled projects. I hope all's well in your world.
I forgot about that! Glad your happy with it.
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP
  #7  
Old 07-30-2013, 07:05 PM
dodge dude94 dodge dude94 is offline
Banned
1998 Dodge Ram 1500
 
Join Date: Jun 2010
Vehicle: 1998 Ram 1500 QCSB 360 4x4
Location: East Texas
Posts: 8,923
Default

Quote:
Originally Posted by UnregisteredUser View Post
You've misspelled wholly, man.



I'll probably try to get around these parts more often, but there's just no telling what I might do.
You should stay. We (I) have missed you.



And you really don't have anything wrong? You've been gone for like 6 months at least. lmao Something should have gone wrong since then.
  #8  
Old 07-30-2013, 07:12 PM
abdodge1500's Avatar
abdodge1500 abdodge1500 is offline
Professional
2000 Dodge Ram 1500
 
Join Date: Feb 2013
Vehicle: 2000 Dodge Ram 1500 Sport 5.9L RCSB 4X2
Location: Lake Mary, Florida
Posts: 197
Default

Quote:
Originally Posted by UnregisteredUser View Post
I don't know what I'm doing wrong here. My truck runs great, gets good fuel economy for what it is, the steering doesn't wander, the heater works great, the transmission is hell for strong, and even the factory original headlights are not hazed. The stupid plenum gasket is still intact, too. And the dash isn't cracked.

I don't get it. What am I doing wrong?
I don't have any of those problems *knock on wood* except for the dash/bezel and heater. wow you're lucky, how do you like that viper trans?
__________________
2000 Dodge Ram 1500 Sport 5.9L ,Auto, RCSB 2WD 3.55 gears, 31in Falken all terrains, leveling kit, Dynomax muffler,30% tint, stock air intake
  #9  
Old 07-30-2013, 08:12 PM
generaljr's Avatar
generaljr generaljr is offline
Professional
Garage is empty, add now
 
Join Date: Apr 2011
Vehicle: lifted 2wd Ion alloys, projectors,ram air hood, steering rack custom grille-bumper
Location: cuyama CA
Posts: 200
Default

are you talking about my truck? none of those issues either ...yet
__________________
  #10  
Old 07-30-2013, 09:40 PM
dhvaughan's Avatar
dhvaughan dhvaughan is offline
Hall Of Fame
Garage is empty, add now
 
Join Date: Jul 2006
Vehicle: 01 1500 4wd
Location: Gainesville, Ga.
Posts: 12,179
Default

Quote:
Originally Posted by UnregisteredUser View Post
I don't know what I'm doing wrong here. My truck runs great, gets good fuel economy for what it is, the steering doesn't wander, the heater works great, the transmission is hell for strong, and even the factory original headlights are not hazed. The stupid plenum gasket is still intact, too. And the dash isn't cracked.

I don't get it. What am I doing wrong?
you must be driving a toyota then.
have you been gone? LOL.
__________________
01 1500 Reg Cab 4wd 5.2 auto 3.55 285/75/16 steps tow hooks sc3815 180 3923 trans cooler filter posilok powertrax (removed) timbren britebox pioneer head rockford amp speaker cobra cb firestick hughes plenum water pump timing chain oil pump rear main hub bearings brakes shocks cracked dash cad bushings seals ujoints trackbar tcase Robert Griffin Trans
Old 07-30-2013, 09:40 PM
Closed Thread
 
 
 




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 10:53 PM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2