What Am I Doing Wrong? - DodgeForum.com


2nd Gen RAM general discussion/NON-tech This section is for general discussions about your 2nd gen RAM. Non tech related RAM threads belong here.

What Am I Doing Wrong?

Closed Thread
 
 
  #1  
Old 07-30-2013, 05:55 PM
UnregisteredUser's Avatar
UnregisteredUser
UnregisteredUser is offline
Champion
Thread Starter
 
Join Date: Apr 2010
Location: Meeker, CO
Posts: 4,976
Default What Am I Doing Wrong?

I don't know what I'm doing wrong here. My truck runs great, gets good fuel economy for what it is, the steering doesn't wander, the heater works great, the transmission is hell for strong, and even the factory original headlights are not hazed. The stupid plenum gasket is still intact, too. And the dash isn't cracked.

I don't get it. What am I doing wrong?

Last edited by UnregisteredUser; 07-30-2013 at 06:07 PM.
  #2  
Old 07-30-2013, 06:11 PM
zman17's Avatar
zman17
zman17 is offline
Retired Moderator - RIP
 
Join Date: May 2008
Location: NH
Posts: 18,729
Default

You regularly do maintenance ? And don't include that Mega Viper in your statement! Good to see you back btw.
  #3  
Old 07-30-2013, 06:31 PM
dodge dude94
dodge dude94 is offline
Banned Goober Smoocher
 
Join Date: Jun 2010
Posts: 8,916
Default

HOLY ****!!!!!


YOU'RE BACK!!


I missed you man. You actually staying?
  #4  
Old 07-30-2013, 06:40 PM
UnregisteredUser's Avatar
UnregisteredUser
UnregisteredUser is offline
Champion
Thread Starter
 
Join Date: Apr 2010
Location: Meeker, CO
Posts: 4,976
Default

Quote:
Originally Posted by zman17 View Post
You regularly do maintenance ?
Is that the problem? Maybe I ought to knock that off so I have an excuse to come around the forum more often.

Oh yeah! My instrument cluster bezel is in great shape, too.

Quote:
Originally Posted by zman17 View Post
Good to see you back btw.
I figured I oughta pop in and say hi as long as I'm just sitting around with nothing but stalled projects. I hope all's well in your world.
  #5  
Old 07-30-2013, 06:44 PM
UnregisteredUser's Avatar
UnregisteredUser
UnregisteredUser is offline
Champion
Thread Starter
 
Join Date: Apr 2010
Location: Meeker, CO
Posts: 4,976
Default

Quote:
Originally Posted by dodge dude94 View Post
HOLY ****!!!!!
You've misspelled wholly, man.

Quote:
Originally Posted by dodge dude94 View Post
You actually staying?
I'll probably try to get around these parts more often, but there's just no telling what I might do.
  #6  
Old 07-30-2013, 08:00 PM
zman17's Avatar
zman17
zman17 is offline
Retired Moderator - RIP
 
Join Date: May 2008
Location: NH
Posts: 18,729
Default

Quote:
Originally Posted by UnregisteredUser View Post
Is that the problem? Maybe I ought to knock that off so I have an excuse to come around the forum more often.

Oh yeah! My instrument cluster bezel is in great shape, too.



I figured I oughta pop in and say hi as long as I'm just sitting around with nothing but stalled projects. I hope all's well in your world.
I forgot about that! Glad your happy with it.
  #7  
Old 07-30-2013, 08:05 PM
dodge dude94
dodge dude94 is offline
Banned Goober Smoocher
 
Join Date: Jun 2010
Posts: 8,916
Default

Quote:
Originally Posted by UnregisteredUser View Post
You've misspelled wholly, man.



I'll probably try to get around these parts more often, but there's just no telling what I might do.
You should stay. We (I) have missed you.



And you really don't have anything wrong? You've been gone for like 6 months at least. lmao Something should have gone wrong since then.
  #8  
Old 07-30-2013, 08:12 PM
abdodge1500's Avatar
abdodge1500
abdodge1500 is offline
Professional
 
Join Date: Feb 2013
Location: Lake Mary, Florida
Posts: 206
Default

Quote:
Originally Posted by UnregisteredUser View Post
I don't know what I'm doing wrong here. My truck runs great, gets good fuel economy for what it is, the steering doesn't wander, the heater works great, the transmission is hell for strong, and even the factory original headlights are not hazed. The stupid plenum gasket is still intact, too. And the dash isn't cracked.

I don't get it. What am I doing wrong?
I don't have any of those problems *knock on wood* except for the dash/bezel and heater. wow you're lucky, how do you like that viper trans?
  #9  
Old 07-30-2013, 09:12 PM
generaljr's Avatar
generaljr
generaljr is offline
Professional
 
Join Date: Apr 2011
Location: cuyama CA
Posts: 200
Default

are you talking about my truck? none of those issues either ...yet
  #10  
Old 07-30-2013, 10:40 PM
dhvaughan's Avatar
dhvaughan
dhvaughan is offline
Hall Of Fame
 
Join Date: Jul 2006
Location: Gainesville, Ga.
Posts: 12,203
Default

Quote:
Originally Posted by UnregisteredUser View Post
I don't know what I'm doing wrong here. My truck runs great, gets good fuel economy for what it is, the steering doesn't wander, the heater works great, the transmission is hell for strong, and even the factory original headlights are not hazed. The stupid plenum gasket is still intact, too. And the dash isn't cracked.

I don't get it. What am I doing wrong?
you must be driving a toyota then.
have you been gone? LOL.
 
 
Closed Thread

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
groenberg
2nd Gen Ram Tech
16
11-01-2015 04:57 PM
nickr519
2nd Gen Ram Tech
2
10-15-2015 08:44 PM
70383roadrunner
2nd Gen Neon
3
10-10-2015 03:28 PM
radjamel
Dodge Caravan
3
10-05-2015 12:58 PM
podfish
1st Gen Dakota
0
09-27-2015 10:07 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 07:53 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send