Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

97 Ram No Check Engine light and wont start

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-05-2011, 08:17 PM
97RAMMAN 97RAMMAN is offline
Registered User
 
Join Date: Apr 2011
Vehicle: 97 Ram 1500 2WD
Location: Mvminnville TN
Posts: 8
Default 97 Ram No Check Engine light and wont start

I have a 97 ram 1500 2wd with the 318. It was running fine then just shut off, it now turns over but won't start. The check engine light doesnt come on with the key in the on position now. It blew the fusible link for the fuel pump in dtc and I replaced that but now still won't start. Any help ya'll could give would be greatly appreciated.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 04-06-2011, 08:08 AM
1969CoronetR/T's Avatar
1969CoronetR/T 1969CoronetR/T is offline
vaffanculo
Dodge Forum Moderator
 
Join Date: Oct 2008
Vehicle: 1969 Coronet R/T - 1969 Mr. Norms Super Bee - 2014 Jeep SRT
Location: Pittsburgh, PA
Posts: 7,833
Default

Welcome to the site. I will move this thread to the second generation Ram section,
FF
Reply With Quote
  #3  
Old 04-06-2011, 08:17 AM
zman17's Avatar
zman17 zman17 is offline
Registered User
Dodge Forum Moderator
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default

Got spark? Getting fuel(check with pressure gauge)? Try swapping ASD relay with the horn relay or similar. How was it running prior to this incident? Try this and see if any codes come up http://dodgeforum.com/forum/2nd-gen-...code-list.html
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP

Last edited by zman17; 04-06-2011 at 08:20 AM..
Reply With Quote
  #4  
Old 04-06-2011, 02:36 PM
weedahoe's Avatar
weedahoe weedahoe is offline
Site Moderator
Dodge Forum Moderator
 
Join Date: Mar 2009
Vehicle: 04 Dodge Ram QC
Location: South GA
Posts: 18,966
TrickedOut DodgeRam Weedahoe1977
Send a message via AIM to weedahoe Send a message via MSN to weedahoe Send a message via Yahoo to weedahoe
Default

Welcome to the site

Do you have any idea why it blew the link? Maybe other electrical damage occurred also
Reply With Quote
  #5  
Old 04-07-2011, 11:06 AM
97RAMMAN 97RAMMAN is offline
Registered User
 
Join Date: Apr 2011
Vehicle: 97 Ram 1500 2WD
Location: Mvminnville TN
Posts: 8
Default

no spark or fuel it was running fine and died i replaced the fusible link and the check engine quit coming on when i the key is turned to the on position. al other lights come on oil pressure, brake ect... and the green light on the cruise contol stays on, think i may of fried computer ????? Tried the key play but no check engine light at all and mine doesn't have the digital speedo.

Last edited by 97RAMMAN; 04-07-2011 at 11:12 AM..
Reply With Quote
  #6  
Old 04-07-2011, 11:09 AM
zman17's Avatar
zman17 zman17 is offline
Registered User
Dodge Forum Moderator
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default

Did you check for codes?
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP
Reply With Quote
  #7  
Old 04-07-2011, 11:16 AM
97RAMMAN 97RAMMAN is offline
Registered User
 
Join Date: Apr 2011
Vehicle: 97 Ram 1500 2WD
Location: Mvminnville TN
Posts: 8
Default

Don't have an obd here, can a guy rent one from the part stores?
Reply With Quote
  #8  
Old 04-07-2011, 11:23 AM
zman17's Avatar
zman17 zman17 is offline
Registered User
Dodge Forum Moderator
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default

Did you look at the link I provided in a previous post?
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP
Reply With Quote
  #9  
Old 04-07-2011, 12:14 PM
97RAMMAN 97RAMMAN is offline
Registered User
 
Join Date: Apr 2011
Vehicle: 97 Ram 1500 2WD
Location: Mvminnville TN
Posts: 8
Default

Yea and it didnt show anything??
Reply With Quote
  #10  
Old 04-07-2011, 12:15 PM
97RAMMAN 97RAMMAN is offline
Registered User
 
Join Date: Apr 2011
Vehicle: 97 Ram 1500 2WD
Location: Mvminnville TN
Posts: 8
Default

Yea and it doesn't show anything???
Reply With Quote
  #11  
Old 04-07-2011, 12:30 PM
zman17's Avatar
zman17 zman17 is offline
Registered User
Dodge Forum Moderator
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default

Swap the ASD relay with the horn relay and see if it starts. If not, remove the pre cat o2 sensor and see what happens.
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP
Reply With Quote
  #12  
Old 04-07-2011, 05:06 PM
97RAMMAN 97RAMMAN is offline
Registered User
 
Join Date: Apr 2011
Vehicle: 97 Ram 1500 2WD
Location: Mvminnville TN
Posts: 8
Default

Tried switching the relays and got nothing going back out now to try the cat sensor
Reply With Quote
  #13  
Old 04-07-2011, 05:38 PM
Mad_Scientist's Avatar
Mad_Scientist Mad_Scientist is offline
Captain
 
Join Date: Nov 2010
Vehicle: 2007 Dodge ram 5.7 4x4
Location: SE Tx
Posts: 632
Default

Quote:
Originally Posted by 97RAMMAN View Post
no spark or fuel it was running fine and died i replaced the fusible link and the check engine quit coming on when i the key is turned to the on position. al other lights come on oil pressure, brake ect... and the green light on the cruise contol stays on, think i may of fried computer ????? Tried the key play but no check engine light at all and mine doesn't have the digital speedo.
If you're not getting spark or fuel, and the asd relay didn't change anything, the o2 wont solve anything.

If the CEL quit coming on all together (doesnt come on when you turn the key), the bulb may be burned out. You can rent a code scanner from most auto parts stores.

I'm thinkin it could be a crank/cam position sensor, or a bad ground somewhere important.

As for eliminating the "bad computer" part. Do the gauges jump when you try to start it? Does the fuel gauge read correctly when the key is in the "on" position? If yes to one or both, your 'puter is fine.
__________________

Mud rig: 2001 ram 5.9 4x4; DD: 2007 ram 5.7 4x4
The problem with this world is that fools and fanatics are always so sure of themselves, and wiser people so full of doubts.- Bertrand Russell
Reply With Quote
  #14  
Old 04-07-2011, 09:35 PM
97RAMMAN 97RAMMAN is offline
Registered User
 
Join Date: Apr 2011
Vehicle: 97 Ram 1500 2WD
Location: Mvminnville TN
Posts: 8
Default

Put a computer in and now when I get fire but no fuel. When i do the key trick now the gas light flashes at the end. Im bout at witts end . Any ideas to try before I drop another $200 on a pump just spent a $250 on the computer. Thanks to everybody for the info and help so far, I'd bout givin up on it till I found this site.
Reply With Quote
  #15  
Old 04-07-2011, 09:36 PM
97RAMMAN 97RAMMAN is offline
Registered User
 
Join Date: Apr 2011
Vehicle: 97 Ram 1500 2WD
Location: Mvminnville TN
Posts: 8
Default

Put a computer in and now I get fire but no fuel. When i do the key trick now the gas light flashes at the end. Im bout at witts end . Any ideas to try before I drop another $200 on a pump just spent a $250 on the computer. Thanks to everybody for the info and help so far, I'd bout givin up on it till I found this site.
Reply With Quote
  #16  
Old 04-07-2011, 10:36 PM
Hjhf1500 Hjhf1500 is offline
Amateur
 
Join Date: Mar 2010
Posts: 41
Default

Swap out the fuel pump relay with the horn relay or A/C relay,maybe the relay shorted and blew the fuse link and fried the computer,the signal terminal from the computer could have shorted to the hot terminal in the relay and shorted it,if the relay checks good do a continuity test on the fuel pump.
Reply With Quote
Old 04-07-2011, 10:36 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 05:25 AM.

Internet Brands, Inc.


Contact Details & Emails